POJ 1753 Flip Game

题目链接:http://poj.org/problem?id=1753

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40497 Accepted: 17593

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source


题目大意:

一个4 * 4的棋盘,上面每一个格子都有一枚棋子,棋子一面是白色一面是黑色,输入为四行长度为四的字符,分别用w表示棋子白色的一面朝上,b表示黑色的一面朝上。每次可以任选一枚棋子,将它以及它上、下、左、右(如果有)的棋子都翻个面,当所有棋子朝上的一面颜色都一样时结束。输出使所有棋子朝上颜色一样需要的最少操作次数,如果无法使所有棋子朝上的颜色一样则输出“Impossible”。

解题思路:

状态压缩 + bfs

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

bool vis[1 << 16];

int flip(int dp, int x, int y){
    if((dp >> (x * 4 + y)) & 1) dp -= 1 << (x * 4 + y);
        else dp += 1 << (x * 4 + y);
    if(x - 1 >= 0){
        if((dp >> ((x - 1) * 4 + y)) & 1) dp -= 1 << ((x - 1) * 4 + y);
            else dp += 1 << ((x - 1) * 4 + y);
    }
    if(x + 1 <= 3){
        if((dp >> ((x + 1) * 4 + y)) & 1) dp -= 1 << ((x + 1) * 4 + y);
            else dp += 1 << ((x + 1) * 4 + y);
    }
    if(y - 1 >= 0){
        if((dp >> (x * 4 + y - 1)) & 1) dp -= 1 <<  (x * 4 + y - 1);
            else dp += 1 << (x * 4 + y - 1);
    }
    if(y + 1 <= 3){
        if((dp >> (x * 4 + y + 1)) & 1) dp -= 1 << (x * 4 + y + 1);
            else dp += 1 << (x * 4 + y + 1);
    }
    return dp;
}

int stk[1 << 16];
int bfs(int dp){
    if(dp == 0 || dp == 65535) return 0;
    int deep = 1, begin = 0, end = 0, next, num;
    vis[dp] = true;
    stk[begin] = dp;
    while(begin < end + 1){
        num = 0;
        for(int k = begin; k <= end; k++){
            for(int i = 0; i <= 3; i++)
                for(int j = 0; j <= 3; j++){
                    next = flip(stk[k], i, j);
                    if(next == 0 || next == 65535) return deep;
                    if(!vis[next]){
                        vis[next] = true;
                        num++;
                        stk[end + num] = next;
                    }
            }
        }
        deep++;
        begin = end + 1;
        end = end + num;
    }
    return -1;
}

int main()
{
    char buf[5];
    int dp;

    dp = 0;
    memset(vis, false, sizeof(vis));
    for(int i = 0; i < 4; i++){
        gets(buf);
        for(int j= 0; j < 4; j++){
            if(buf[j] == 'b') dp += 1 << (i * 4 + j);
        }
    }
    int ans = bfs(dp);
    if(ans != -1) printf("%d\n", ans);
        else printf("Impossible\n");
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值