模板题-----DFS深度搜索 HDU2952

Counting Sheep

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2144    Accepted Submission(s): 1412


Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.


Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.
 

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
 

Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100
 

Sample Input
  
  
2 4 4 #.#. .#.# #.## .#.# 3 5 ###.# ..#.. #.###
 

Sample Output
  
  
6 3
#include<cstdio>
#include<iostream>
#include<string.h>
#define mnum 120
using namespace std;
char tu[mnum][mnum];int vis[mnum][mnum];
const int step_x[4]={0,0,-1,1};
const int step_y[4]={1,-1,0,0};
int h,w,cnt;
void dfs(int i,int j)
{	
	if(tu[i][j]=='#'&&vis[i][j]==0)//递归函数使用的条件(这里的条件是一旦找到'#')
	{
		vis[i][j]=1; //一定要注意做标记,好像这个叫记忆化搜索!
		for(int k=0;k<4;k++)  //每个递归点执行什么操作(这里是从递归点向4个方向再递归,直到遇到递归边界为止)
		{
			if(i+step_x[k]<1||i+step_x[k]>h)  //递归边界注意把控好,把控不好时数组很容易越界!
			continue;
			if(j+step_y[k]<1||j+step_y[k]>w)
			continue;
			dfs(i+step_x[k],j+step_y[k]);
		}
	} 
        else
        return;//(递归边界)
 }
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{	memset(vis,0,sizeof(vis));
		memset(tu,'.',sizeof(tu));
		scanf("%d%d",&h,&w);
		getchar();
		for(int i=1;i<=h;i++)
		{
		for(int j=1;j<=w;j++)
		{
			scanf("%c",&tu[i][j]);
		}
		getchar();
		}
		cnt=0;
		for(int i=1;i<=h;i++)
		for(int j=1;j<=w;j++)
		{	if(tu[i][j]=='.'||vis[i][j])
			continue;
			dfs(i,j);
			cnt++;
		}
		printf("%d\n",cnt);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值