Tempter of the Bone HDU - 1010

问题:

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

大意:

s :起始位置;D:终点位置;X:墙; “ . ” :路;每一个点只能走一次,问能不能在T时刻,从S走到D。

思路:

这个题广搜不好写,路径不好标记。深搜开始也写超了,请教了大佬说要采用奇偶剪枝。关于奇偶剪枝,假设当前位置为x,y.目标位置为dx,dy。而d=abs(x-dx)+abs(y-dy)就是你最少需要多少步你才能走到dx,dy位置,然后你实际走到终点的所用的步数的奇偶性要与d保持一致(就是从当前位置要用奇数步走到目标位置 就是奇数步,偶数步就是偶数步,不管你怎么拐弯奇偶性是不变的。关于这个是为什么,我也是自己在本子上画个坐标轴慢慢体会的!尴尬)。

代码:

 

#define N 10
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m,T,book[N][N],a,b,c,d;
int net[4][2]= {0,1,0,-1,1,0,-1,0};
char k[N][N];
int dfs(int x,int y,int step)
{
    if(step==T&&k[x][y]=='D')
        return 1;
    if(step>=T)return 0;
    int dd=abs(x-c)+abs(y-d);
    if(dd>T-step)return 0;//如果最少步数也大于了剩余步数,就无论如何也到不了了
    if(dd%2!=(T-step)%2)return 0;//奇偶剪枝
    for(int i=0; i<4; i++)
    {
        int tx=x+net[i][0];
        int ty=y+net[i][1];
        if(tx<0||ty<0||tx>=n||ty>=m||book[tx][ty]||k[tx][ty]=='X')
            continue;
        book[tx][ty]=1;
        if(dfs(tx,ty,step+1))
            return 1;
        book[tx][ty]=0;
    }
    return 0;
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&T)&&(n||m||T))
    {
        memset(book,0,sizeof(book));
        for(int i=0; i<n; i++)
            scanf("%s",k[i]);
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
            {
                if(k[i][j]=='S')
                {
                    a=i;
                    b=j;
                }
                if(k[i][j]=='D')
                {
                    c=i;
                    d=j;
                }
            }
        book[a][b]=1;
        if(dfs(a,b,0))
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值