PAT 05-树7. File Transfer (25)

该问题涉及一个由N台电脑组成的网络,每台电脑用1到N的正整数表示。输入包含双向连接,用于在电脑间传输文件。任务是判断任意两台电脑间能否传输文件,并在最后给出网络的连通性状态。
摘要由CSDN通过智能技术生成

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2<=N<=104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." wherek is the number of connected components in this network.

Sample Input 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
Sample Output 1:
no
no
yes
There are 2 components.
Sample Input 2:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
Sample Output 2:
no
no
yes
yes
The network is connected.


#include <stdio.h>
#include <stdlib.h>

#define ElementType int

typedef struct
{
	ElementType Data;
	int parent;
}SetType;

SetType* Create(int Size)
{
	SetType* S;
	int i;
	
	S = (SetType*)malloc(Size * sizeof(SetType));
	
	for(i = 0; i < Size; i++)
	{
		S[i].Data = i + 1;
		S[i].parent = -1;
	}
	
	return S;
}

int Find(SetType* S, ElementType a)
{
	int i = a - 1;
	if(S[i].parent < 0)
	{
		return i;
	}
	else
	{
		return Find(S, S[S[i].parent].Data);
	}
}

int Union(SetType* S, ElementType a, ElementType b)
{
	int ra, rb;

	ra = Find(S, a);
	rb = Find(S, b);
	if(ra != rb)
	{
		if(S[ra].parent > S[rb].parent)
		{
			S[ra].parent = rb;
			S[rb].parent--;
		}
		else
		{
			S[rb].parent = ra;
			S[ra].parent--;
		}		
		return 1;
	}	
	else
		return 0;	
}

int main()
{
	int N;
	char c;
	int a, b;
	int ra, rb;
	int i;
	int count,flag;
	SetType* S;
	scanf("%d", &N);
	
	S = Create(N);

	count = N;
	while(1)
	{
		scanf("%c", &c);
		
		if(c == 'C')
		{
			scanf("%d %d", &a, &b);
			ra = Find(S, a);
			rb = Find(S, b);
			if(ra == rb)
			{
				printf("yes\n");
			}
			else
			{
				printf("no\n");
			}
		}
		else
		if(c == 'I')
		{
			scanf("%d %d", &a, &b);
			flag = Union(S, a, b);
			if(flag == 1)
				count--;
		}
		else
		if(c == 'S')
		{
			break;
		}
	}
	
	if(count == 1)
		printf("The network is connected.");
	else
		printf("There are %d components.", count);
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值