hdu-1010Tempter of the Bone-dfs

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1010


Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)



Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

 


Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

 


Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

 


Sample Input

 
 
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

 


Sample Output

 
 
NO YES


Recommend

JGShining   |   We have carefully selected several similar problems for you:  1016 1241 1242 1072 1312 


题目分析:

最近dp做的多,拿到之后第一个想到的是dp,但是仔细一想是搜索。不过如果简单的套路是会超时的,需要用到优化。

这里有一个优化是,如果t>最短时间,那么只能是大偶数。

代码

#include <cstdio>
#include <cstring>
#include <cstdlib>

char maze[8][8];
int dx[4] = {-1, 0, 1, 0};
int dy[4] = {0, -1, 0, 1};
bool vis[8][8];

int n, m, t;
bool flag;

void Dfs(int x, int y, int tm)
{
    if (flag||tm>t)//已经找到了或者当前时间已经超时了就不用找了
    {
        return;
    }
    if (maze[x][y] == 'D' || tm == t)
    {
        if (maze[x][y] == 'D' && tm == t)
        {
            flag = true;
        }
        return;
    }
    for (int i = 0; i < 4; i++)
    {
        int nx = x + dx[i];
        int ny = y + dy[i];
        if (nx >= 0 && nx < n && ny >= 0 && ny < m && vis[nx][ny] == false && maze[nx][ny] != 'X')
        {
            vis[nx][ny] = true;
            Dfs(nx, ny, tm + 1);
            vis[nx][ny] = false;
        }
    }
}

int main()
{
    while (scanf("%d%d%d", &n, &m, &t) == 3 && n + m + t)
    {
        getchar();//吃掉最后一个回车
        int bx, by;
        int ex, ey;
        for (int i = 0; i < n; i++)
        {
            for (int j = 0; j < m; j++)
            {
                scanf("%c", &maze[i][j]);
                if (maze[i][j] == 'S')
                {
                    bx = i;
                    by = j;
                }
                if (maze[i][j] == 'D')
                {
                    ex = i;
                    ey = j;
                }
            }
            getchar();
        }

        //起点终点的最短距离就是(abs(ex-bx) + abs(ey-by)
        //必须比最少步数多偶数
        if(abs(ex-bx) + abs(ey-by) > t || (t - (abs(ex-bx) + abs(ey-by))) % 2 == 1)
        {
            puts("NO");
            continue;
        }
        memset(vis, false, sizeof(vis));
        flag = false;
        vis[bx][by]=1;
        Dfs(bx, by, 0);
        puts(flag ? "YES" : "NO");
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值