poj1018Communication System-dp

题目地址:http://poj.org/problem?id=1018


Communication System
Time Limit: 1000MS Memory Limit: 10000K
  

Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices.
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.

Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.

Sample Input

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output

0.649


题目大意

t组测试数据,每一组n种机器,每一种m个,带宽和价钱分别是b,p

必须买n种机器,每种必须买一个,b表示买的机器的最小带宽,p表示买的机器的所有钱。

求一个b/p最大值。

解题思路

一开始想用分组背包,最后弄了半天没弄出来,还是看了题解写了一个dp,如果有大神能知道为什么不能用分组背包求给我讲解。

dp【i】【j】表示前i个公司,最小带宽为j的情况下,用的最少钱。

代码

#include <cstring>
#include <cstdio>
#include <iostream>
const int maxn=0x3f3f3f3f;
using namespace std;

int main()
{
    int  t;
    scanf("%d",&t);
    while(t>0)
    {
        int i,j,k;
        int n;
        int maxb=0;
        int b[110][110],p[110][110];
        int dp[110][1100];
        int m[110];//第i个产品有m个制造商(每一组有m个物品)
        memset(b,0,sizeof(b));
        memset(p,0,sizeof(p));
        memset(dp,maxn,sizeof(dp));

        scanf("%d",&n);
        for(i=1;i<=n;++i)//n个产品(n组)
        {
            scanf("%d",&m[i]);
            for(j=1;j<=m[i];++j)
            {
                scanf("%d%d",&b[i][j],&p[i][j]);
                if(maxb<b[i][j]) maxb=b[i][j];
            }
        }
        for(i=1;i<=m[1];++i)
        {
            dp[1][b[1][i]]=min(dp[1][b[1][i]],p[1][i]);//第1种设备有可能
        }

        for(i=2;i<=n;++i)//第i种机器
        {
            for(j=1;j<=m[i];++j)//第i种机器的m个可选情况
            {
                for(int k=1;k<=maxb;++k)//枚举带宽
                {
                    //不管怎么样,第i种设备必须选一个
                    if(b[i][j]<=k)//如果选第j个设备之后最小带宽变了
                        dp[i][b[i][j]]=min(dp[i][b[i][j]], dp[i-1][k] + p[i][j]);
                    else//选了这件物品带宽不变,就等于前i-1种设备就达到这种带宽了
                        dp[i][k]=min(dp[i][k], dp[i-1][k] + p[i][j]);
                }
            }
        }

        double ans=0;
        for(i=1;i<=maxb;++i)
            ans=max(ans,1.0*i/dp[n][i]);
        printf("%.3f\n",ans);
        t--;
    }
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值