poj1157 LITTLE SHOP OF FLOWERS-dp

Time Limit: 1000MS 
Memory Limit: 10000K

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.
 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

723-5-2416

2 (begonias)

521-41023

3 (carnations)

-21

5-4-2020

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

Input

  • The first line contains two numbers: F, V.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.


  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.
  • F <= V <= 100 where V is the number of vases.
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

题目大意

现在有F束花,V个花瓶,并且F<=V,现在要将F束花插到V个花瓶中去,现在有这些要求,花是按序号来的,假设i<j那么花i必须放在花j的左边,然后每一束花插到某一个瓶子是有一个美学价值的,而且每个花瓶只能插一束花,现在要你算出怎么放,能够使美学价值最大

ans【i】【j】表示前i朵花插前j个瓶子的最大价值

a【i】【i】表示第i朵花插第i个瓶子的价值

我们可以这样认为,第i朵花插入第j个瓶子中吗?
插入的话 ans[i-1][j-1]+a[2][3]
不插入的话 ans[i][j-1]

所以ans[i][j]=max(ans[i][j-1],ans[i-1][j-1]+a[i][j])

再说一下初始化的问题,前i朵花放前i个瓶子里只有一种放法

ans[i][i] = ans[i-1][i-1]+a[i][i]

代码
#include <cstring>
#include <cstdio>
#include <iostream>
#include <vector>
#define INF 0x3f3f3f3f
const int maxn=5010;
using namespace std;
int ans[110][110];
int a[110][110];
int main()
{
    int f,v;
    int i,j;
    scanf("%d%d",&f,&v);
    for(i=1;i<=f;++i)
    {
        for(j=1;j<=v;++j)
        {
            scanf("%d",&a[i][j]);
        }
        //前i朵花放前i个瓶子里只有一种放法
        ans[i][i] = ans[i-1][i-1]+a[i][i];
    }

    for(i=1;i<=f;++i)
    {
        //枚举第i朵花放在哪个瓶子里
        for(j=i+1;j<=v;++j)//花瓶数量大于等于花的数量
        {
            //不放这个花瓶=前i朵花放前j-1个花瓶里
            //放这个花瓶=前i-1朵花放前j-1个花瓶里+当前价值
            ans[i][j]=max(ans[i][j-1],ans[i-1][j-1]+a[i][j]);
        }
    }
    printf("%d\n",ans[f][v]);
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值