hdu 5879 Cure -ICPC网络赛青岛赛区

Cure

Problem Description

Given an integer n , we only want to know the sum of 1/k2 where k from 1 to n .

Input

There are multiple cases.
For each test case, there is a single line, containing a single positive integer n .
The input file is at most 1M.


Output

The required sum, rounded to the fifth digits after the decimal point.

 

Sample Input

 
 
1 2 4 8 15


Sample Output

 
 
1.00000 1.25000 1.42361 1.52742 1.58044

 


题意

求1/1到n方分之一求和


解题思路

当n很大的时候趋近于π*π/6,n较小时手动算

通过打表尝试,找到差不多当n>110300时就会大于等于π*π/6

所以小的时候打表,打的时候直接输出


代码

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

double a[120000];
char s[10000000];
int main()
{
    int i;
    for(i=1;i<=110300;++i)
    {
        a[i]=1.0/i/i; //写成 1.0/(i*i)出错
    }
    for(i=2;i<=110300;++i)
        a[i]+=a[i-1];

    while(scanf("%s",s)==1)
    {
        int len=strlen(s);
        if(len>=7)
            puts("1.64493");
        else
        {
            int n=0;
            for (int i = 0; i < len; i++)
            {
                n = n * 10 + s[i] - '0';
            }
            if(n>=110300) puts("1.64493");
            else printf("%.5f\n",a[n]);
        }
    }

    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值