hdu 5900 QSC and Master -ICPC网络赛沈阳赛区-区间dp

QSC and Master

Problem Description

Every school has some legends, Northeastern University is the same.

Enter from the north gate of Northeastern University,You are facing the main building of Northeastern University.Ninety-nine percent of the students have not been there,It is said that there is a monster in it.

QSCI am a curious NEU_ACMer,This is the story he told us.

It’s a certain period,QSCI am in a dark night, secretly sneaked into the East Building,hope to see the master.After a serious search,He finally saw the little master in a dark corner. The master said:

“You and I, we're interfacing.please solve my little puzzle!

There are N pairs of numbers,Each pair consists of a key and a value,Now you need to move out some of the pairs to get the score.You can move out two continuous pairs,if and only if their keys are non coprime(their gcd is not one).The final score you get is the sum of all pair’s value which be moved out. May I ask how many points you can get the most?

The answer you give is directly related to your final exam results~The young man~”

QSC is very sad when he told the story,He failed his linear algebra that year because he didn't work out the puzzle.

Could you solve this puzzle?

(Data range:1<=N<=300
1<=Ai.key<=1,000,000,000
0<Ai.value<=1,000,000,000)

 


Input

First line contains a integer T,means there are T(1≤T≤10) test case。

  Each test case start with one integer N . Next line contains N integers,means Ai.key.Next line contains N integers,means Ai.value.

 


Output

For each test case,output the max score you could get in a line.

 


Sample Input

 
 
3 3 1 2 3 1 1 1 3 1 2 4 1 1 1 4 1 3 4 3 1 1 1 1

 


Sample Output

 
 
0 2 0

 


Source

2016 ACM/ICPC Asia Regional Shenyang Online

 

题目大意

给出n对数key,val表示当前这对数的键值和权值,如果满足key值得最大公约数不为一,可以操作将连续的两个数合并,得到的价值是两个数的权值和

需要注意的是 每次合并两个数之后,这两个数就会消失,然后本来不相邻的两张牌也变成相邻的了也可以进行合并


解题思路

这道题其实和经典区间dp石子合并挺像的又有区别,需要加一步特判,如果中间的牌都被合并消失了,那么再将两头的合并


代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
typedef long long ll;
const int maxn = 305;
ll dp[maxn][maxn];
ll key[maxn];
ll val[maxn];
ll sum[maxn];
int n;
ll gcd(ll a,ll b)
{
    return b == 0 ? a : gcd(b, a % b);
}
void DP()
{
    memset(dp,0,sizeof(dp));
    for(int len=1;len<=n-1;len++)//不包括本身的长度
    {
        for(int i=1;i+len<=n;i++)//区间左端点
        {
            int j=i+len;//右端点

            if(gcd(key[i],key[j])>1)
            {
                if(j==i+1) dp[i][j] = val[i]+val[j];
                //如果【i,j】中间的全都能消除,那么本来不相邻的也相邻了
                else if(dp[i+1][j-1]==sum[j-1]-sum[i]) dp[i][j] = max(dp[i][j],dp[i+1][j-1]+val[i]+val[j]);
            }
            //枚举断点,整合区间取最大
            for(int k=i;k<j;k++)
                dp[i][j] = max(dp[i][j],dp[i][k]+dp[k+1][j]);
        }
    }
    printf("%I64d\n",dp[1][n]);
}
int main()
{
    int T;cin>>T;
    while(T--)
    {
        memset(sum,0,sizeof(sum));
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%I64d",&key[i]);
        for(int i=1;i<=n;i++) scanf("%I64d",&val[i]),sum[i]=val[i]+sum[i-1];
        DP();
    }
}



 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值