L2-005. 集合相似度 - 天梯赛练习


L2-005. 集合相似度

  

给定两个整数集合,它们的相似度定义为:Nc/Nt*100%。其中Nc是两个集合都有的不相等整数的个数,Nt是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度。

输入格式:

输入第一行给出一个正整数N(<=50),是集合的个数。随后N行,每行对应一个集合。每个集合首先给出一个正整数M(<=104),是集合中元素的个数;然后跟M个[0, 109]区间内的整数。

之后一行给出一个正整数K(<=2000),随后K行,每行对应一对需要计算相似度的集合的编号(集合从1到N编号)。数字间以空格分隔。

输出格式:

对每一对需要计算的集合,在一行中输出它们的相似度,为保留小数点后2位的百分比数字。

输入样例:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
输出样例:
50.00%
33.33%


代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <stack>
#include <sstream>
#include <string>
using namespace std;

const int maxn = 510;
set<int> s[55];

int main()
{
    int n;
    int temp;
    scanf("%d",&n);
    for(int i = 0;i<n;++i){
        int m;
        scanf("%d",&m);
        for(int j = 0;j<m;++j){
            scanf("%d",&temp);
            s[i].insert(temp);
        }
    }
    int k;
    scanf("%d",&k);

    for(int i = 0; i<k; ++i){
        int same = 0,sum = 0;
        int a,b;
        scanf("%d%d",&a,&b);
        set<int>::iterator it;
        for(it = s[a-1].begin();it!=s[a-1].end();++it){
            if(s[b-1].find(*it)!=s[b-1].end())
                same ++;
        }
        sum = s[a-1].size()+s[b-1].size()-same;
        printf("%.2f%%\n",same*1.0/sum*100);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值