L2-008. 最长对称子串
对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定"Is PAT&TAP symmetric?",最长对称子串为"s PAT&TAP s",于是你应该输出11。
输入格式:
输入在一行中给出长度不超过1000的非空字符串。
输出格式:
在一行中输出最长对称子串的长度。
输入样例:Is PAT&TAP symmetric?输出样例:
11
解题思路
数据量较小,所以枚举每个位置,从当前位置往左右两边看,有多少个对称的,
i为字符串当前字符的下标。
当回文字串为奇数的时候,j表示区间 i-j 到 i+j 构成的回文字串长度;
当回文字串长度为偶数的时候,j表示 i+1 左边 j 个字符一直到i右边j个字符的回文字串长度
当回文字串长度为偶数的时候,j表示 i+1 左边 j 个字符一直到i右边j个字符的回文字串长度
代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <stack>
#include <sstream>
#include <string>
using namespace std;
const int maxn = 510;
int main(){
string s;
getline(cin,s);
int len = s.length();
int ans = 0,temp;
for(int i =0;i<len;++i){
///如果是奇数个字符
temp = 1;///每个位置都是从1开始(加上他本身,但是他本身不算在对称里面如 A&A )
for(int j = 1;j<len;++j){
if(i-j < 0 || i+j >= len || s[i-j] != s[i+j])
break;
temp += 2;
}
ans = ans > temp ? ans : temp;
///如果是偶数个字符
temp = 0;///每个位置都是从0开始
for(int j = 1;j<len;++j){
if(i-j+1 < 0 || i+j >= len || s[i-j+1] != s[i+j])
break;
temp += 2;
}
ans = ans > temp ? ans : temp;
}
printf("%d",ans);
return 0;
}