L1-039. 古风排版 - 天梯赛

L1-039. 古风排版


中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。

输入格式:

输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。

输出格式:

按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)

输入样例:
4
This is a test case
输出样例:
asa T
st ih
e tsi
 ce s


解题思路

水题。。。直接模拟,当时看通过率很低就没做,,心累。。。

先从左往右竖着放,然后在从右往左输出;


代码

#include <iostream>
#include <cstdio>
#include <map>
#include <cmath>
#include <string.h>
#include <algorithm>
#include <set>
#include <sstream>
#include <vector>
#include <queue>
#include <stack>
using namespace std;

const int maxn = 10000+10;
const int INF = 0x3f3f3f3f;



int main()
{
    char a[100][1001];
    int n;///n行
    scanf("%d",&n);
    getchar();
    char s[1010];
    gets(s);
    int len = strlen(s);
    int cnt = 0;
    int j,f = 0;
    ///初始化
    for(int i =0;i<100;i++){
        for(int j =0;j<1001;++j){
            a[i][j] = ' ';
        }
    }


    for(j = 0;cnt<len;++j){
        for(int i = 0;i<n;++i){
            a[i][j] = s[cnt];
            cnt++;
            if(cnt>=len) break;///这里要注意
        }
    }

    for(int i = 0; i<n;++i){
        for(int k = j-1;k>=0;--k){
            printf("%c",a[i][k]);
        }
        puts("");
    }


    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值