poj 3320 Jessica's Reading Problem - 尺取法

poj 3320 Jessica's Reading Problem

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2



题意

一本p页码的书每页包含一个知识点,每个知识点可能在好几个页里都提到,希望阅读一段连续的页码,使得所有知识点都包含到,问最少读多少页


解题思路

用 set 存知识,然后尺取法求最少页数。


代码

#include <iostream>
#include <cstdio>
#include <map>
#include <cmath>
#include <string.h>
#include <algorithm>
#include <set>
#include <sstream>
using namespace std;

const int maxn = 1000010;
const int INF = 0x3f3f3f3f;
int a[maxn];

int main()
{

    map<int,int> mp;
    set<int> num;
    int l = 0,r =0,n;
    int ans  = INF;
    int cnt = 0;

    scanf("%d",&n);
    for(int i = 0;i<n;++i){
        scanf("%d",&a[i]);
        num.insert(a[i]);
    }
    int m = num.size();///有多少种类别

    while(l<=r){
        while(cnt<m && r<n){///直到包括全部知识点,或者没办法包括全部知识点
            mp[a[r]] ++;
            if(mp[a[r]] == 1) cnt++;///新的一种内容

            r++; ///后移看下一个内容
        }

        if(cnt<m) break;///没办法包括全部知识点

        ans = min(r-l,ans);

        ///左区间右移
        mp[a[l]]--;
        if(mp[a[l]] == 0) cnt--;///右移导致种类变少
        l++;
    }
    printf("%d",ans);

    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值