HDU 6043 KazaQ's Socks - 2017多校联盟1 第11题 -规律

KazaQ's Socks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 154    Accepted Submission(s): 112


Problem Description
KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are n1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k -th day.
 

Input
The input consists of multiple test cases. (about 2000 )

For each case, there is a line contains two numbers n,k (2n109,1k1018) .
 

Output
For each test case, output " Case # x : y " in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.
 

Sample Input
  
  
3 7 3 6 4 9
 

Sample Output
  
  
Case #1: 3 Case #2: 1 Case #3: 2
 

Source



/*
一共n双袜子编号1~n,每天早上选取编号最小的一双穿,
当晚上发现只剩一双袜子能穿时,把之前的袜子都洗了,
明天晚上就可以穿了。
问第k天穿的是编号为几的袜子


思路:
规律题,以四双为例,穿袜子的序列为:
[1 2 3 4] [1 2 3]  [1 2 4] [1 2 3]…[...]………
前n天 就是相应编号,超过n天后有规律,周期是n-1,
第一个周期是 [1 2 3]
第二个周期是 [1 2 4]
第三个周期是 [1 2 3]
……………………………………………………
第奇数个周期是[1 2 .... n-1];
第偶数个周期是[1 2 .... n];
*/

#include <iostream>
#include <cstdio>
using namespace std;

typedef unsigned long long ull;

ull n,k;

int main()
{
    int t = 0;
    while (cin >> n >> k){
        t++;

        if (k <= n) {
            cout << "Case #" << t << ": " << k << endl;
        }
        else{
            k -= n;
            if (k % (n-1) != 0){
                cout << "Case #" << t << ": " << k % (n-1) << endl;
            }
            else{
                if ((k / (n-1)) % 2 == 0){
                    cout << "Case #" << t << ": " << n << endl;
                }
                else{
                    cout << "Case #" << t << ": " << n-1 << endl;
                }
            }
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值