hdu 6047 Maximum Sequence - 单调队列 - 2017多校联盟2 3题

Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 408    Accepted Submission(s): 219


Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1a2n . Just like always, there are some restrictions on an+1a2n : for each number ai , you must choose a number bk from {bi}, and it must satisfy ai ≤max{ aj -j│ bk ≤j<i}, and any bk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{ 2nn+1ai } modulo 109 +7 .

Now Steph finds it too hard to solve the problem, please help him.
 

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
 

Output
For each test case, print the answer on one line: max{ 2nn+1ai } modulo 109 +7。
 

Sample Input
  
  
4 8 11 8 5 3 1 4 2
 

Sample Output
  
  
27
Hint
For the first sample: 1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;
 

Source
 



/*
题意
给定序列{a} {b}
当在区间[n+1,2n]时 ai ≤ max{aj-j│bk ≤j<i}, bk来自{bi},每个bk只能用一次
求sum(an+1 +....+ a2n)

题解
要求和最大,那么ai要尽可能的大,所以ai = max{aj-j│bk ≤j<i}
即求 区间[bk,i)中aj-j最大的值。
因为每个bk只能用一次,越往后j越大容易导致aj-j越小,所以采用贪心
尽早的把max aj-j使用掉,所以前期区间越大越好
给b排序后 按从小到大的序列使用b,得到的结果是最大的。
每次选取区间[bk,i)中最大的aj-j值,使用单调队列维护,线段树、优先队列亦可
*/

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>
#include <stdlib.h>
#include <set>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;

const int maxn = 250000+100;
const int mod = 1e9+7;
struct data{
    int pos;
    int val;
};
data a[maxn];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){

        int b[maxn];
        deque <data> q;
        for(int i = 0;i<n;++i){
            scanf("%d",&a[i].val);
            a[i].pos = i+1;
            a[i].val = a[i].val-a[i].pos;
        }
        for(int i = 0;i<n;++i) scanf("%d",&b[i]);
        sort(b,b+n);
        for(int i =0;i<n;++i){
            ///从a[0]~a[i]区间,队尾元素比a[i]还小,队尾就没用了
            while(!q.empty() && q.back().val < a[i].val){
                q.pop_back();
            }
            q.push_back(a[i]);
        }

        int bpos = 0;///b从最小的开始用
        data temp;
        long long  ans = 0;
        while(bpos<n){
            while(!q.empty() && q.front().pos < b[bpos]){///队首元素已经不在区间内了
                q.pop_front();
            }
            ans = (ans+q.front().val)%mod;
            temp.pos =  bpos+n+1;
            temp.val = q.front().val-temp.pos;

            while(!q.empty() && q.back().val <= temp.val){///队尾元素比当前值还小,队尾就没用了
                q.pop_back();
            }
           q.push_back(temp);
            bpos++;
        }

        printf("%lld\n",ans);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值