hdu6124 Euler theorem -多校联盟7

Euler theorem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 383    Accepted Submission(s): 311


Problem Description
HazelFan is given two positive integers a,b , and he wants to calculate amodb . But now he forgets the value of b and only remember the value of a , please tell him the number of different possible results.
 

Input
The first line contains a positive integer T(1T5) , denoting the number of test cases.
For each test case:
A single line contains a positive integer a(1a109) .
 

Output
For each test case:
A single line contains a nonnegative integer, denoting the answer.
 

Sample Input
  
  
2 1 3
 

Sample Output
  
  
2 3




/*
题意
a对任意一个数取余能得到几种不同的结果

题解
从a/2+1开始到a对a取余数结果都不一样,加上>a时候的情况。共(a+1)/2+1种
*/
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
 using namespace std;

const int maxn = 1e7+10;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int a;
        scanf("%d",&a);
        printf("%d\n",(a+1)/2+1);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值