hdu 4027 Can you answer these queries?-特殊的单节点更新

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 19391    Accepted Submission(s): 4584


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
  
  
Case #1: 19 7 6


/*
题意:
给你n个数,n<=100000,每个数不超过2^63
两种操作
0 x y 表示从x到y每个数都开方取下正
1 x y 表示从x到y每个数求和

题解:
2^63开方 6~7次变为1之后就不用操作了,也就是当sum==区间长度时候
这道题类似hdu5239平方后mod 9223372034707292160 即2 ^ 63 - 2 ^ 31
即任意数的平方MOD此数,重复操作至多29次就会进入一个不变的数。

*/

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>
#include <cmath>
using namespace std;
typedef long long ll;

const int maxn = 101000*4;
const int INF = 0x3f3f3f3f;

struct node{
    int l,r;
    ll sum;
}tree[maxn];

void build(int node,int b,int e){
    int mid = (b+e)/2;
    tree[node].l = b;
    tree[node].r = e;

    if(b==e) {
       scanf("%lld",&tree[node].sum);
       return;
    }
    build(node*2,b,mid);
    build(node*2+1,mid+1,e);
    tree[node].sum = tree[node*2].sum + tree[node*2+1].sum;
}


void update(int node ,int ql,int qr){
    if(tree[node].sum == (tree[node].r-tree[node].l+1)) return;
    if(tree[node].l == tree[node].r){
        tree[node].sum = (ll)sqrt(tree[node].sum);
        return;
    }

    int mid  = (tree[node].l + tree[node].r)/2;
    if(ql<=mid) update(node*2,ql,qr);
    if(qr>mid) update(node*2+1,ql,qr);
    tree[node].sum = tree[node*2].sum + tree[node*2+1].sum;
}

ll query(int node,int ql,int qr){
    ll ans1 = 0,ans2 = 0;
    if(ql<=tree[node].l && qr>=tree[node].r)
        return tree[node].sum;

    int mid = (tree[node].l + tree[node].r)/2;
    if(ql<=mid) ans1 = query(node*2,ql,qr);
    if(qr>mid) ans2 = query(node*2+1,ql,qr);
    return ans1+ans2;
}


int main(){
    int n,m;
    int icase = 1;
    while(scanf("%d",&n)!=EOF){
        printf("Case #%d:\n",icase++);
        build(1,1,n);
        scanf("%d",&m);
        while(m--){
            int t,x,y;
            scanf("%d%d%d",&t,&x,&y);
            if(x>y) swap(x,y);///这里有坑
            if(t==0) update(1,x,y);
            if(t==1) printf("%lld\n",query(1,x,y));
        }
        puts("");
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值