1340:【例3-5】扩展二叉树

1340:【例3-5】扩展二叉树
时间限制: 1000 ms         内存限制: 65536 KB
【题目描述】
由于先序、中序和后序序列中的任一个都不能唯一确定一棵二叉树,所以对二叉树做如下处理,将二叉树的空结点用·补齐,如图所示。我们把这样处理后的二叉树称为原二叉树的扩展二叉树,扩展二叉树的先序和后序序列能唯一确定其二叉树。
现给出扩展二叉树的先序序列,要求输出其中序和后序序列。
【输入】
扩展二叉树的先序序列。
【输出】
输出其中序和后序序列。
【输入样例】
ABD..EF..G..C..
【输出样例】
DBFEGAC
DFGEBCA

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node{
	char data;
	int left,right;
}t[1000];
int num=1;
void build(int root){
	char ch;
	cin>>ch;
	if(ch!='.'){
		t[root].data=ch;
		t[root].left=++num;
		build(t[root].left);
		t[root].right=++num;
		build(t[root].right);
	}
}
void inorder(int root){
	if(t[root].data==0) return;
	inorder(t[root].left);
	cout<<t[root].data;
	inorder(t[root].right);
}
void postorder(int root){
	if(t[root].data==0) return;
	postorder(t[root].left);
	postorder(t[root].right);
	cout<<t[root].data;
}
int main()
{
	build(1);
	inorder(1);
	cout<<endl;
	postorder(1);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

宏阳李老师

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值