//二分搜索//1e-8是什么神奇的东西?//Pie------三F

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655

解题思路:
现在好像有点明白二分怎么用了。首先得确定一个答案所在的范围,比如这道题就是大于0小于最大的饼的面积。还必须有一个能确定mid是新的上界还是下界的条件,在这道题里就是分的份数和人数的对比,如果份数多了答案就应该更小,份数少了答案就应该更大。

然后因为这道题上界和下界都是double型,两个double型绝对值差在10的负8次方以内就视作相等。e就是10的意思?1e-8就是10的负8次方?但是这道题里用10的负8次方会超时,因为精度要求没那么高,10的负4次方就可以了,不会超时。

#include <stdio.h>   
#include <math.h>  
#include <algorithm>  
using namespace std;

const double pi=3.14159265358979323846;
double area[10010];
int n,f;

bool cmp(double a,double b)
{
    return a>b;
}

int check(double m)
{
    int sum=0;
    for(int i=1;i<=n;i++)
    {
        sum+=(int)(area[i]/m);
        if(sum>=f+1) return 1;
    }
    return 0;
}

int main()
{
    int t;
    double l,r,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&f);
        for(int i=1;i<=n;i++)
        {
            scanf("%lf",&area[i]);
            area[i]=area[i]*area[i]*pi;
        }
        sort(area+1,area+n+1,cmp);
        l=0;
        r=area[1];
        while(fabs(l-r)>1e-5)
        {
            m=(l+r)/2;
            if(check(m)==1)
                l=m;
            else
                r=m;
        }
        printf("%.4lf\n",l);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值