//二分搜索//把left=mid改成left=mid+1居然就不超时了?!//Monthly Expense------三G

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.
FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.
FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
Input
Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

解题思路:
首先要找到答案所在的范围,下界应该是n个数中的最大值,这个时候有n个fajomonths,上界应该是n个数的和,这个时候只有一个fajomonths。
对于每一个mid,遍历一遍n个数,看能分出多少个区间。如果区间数小于等于m,证明每一份分大了,right=mid;如果区间数大于m,证明每一份分小了,left=mid+1。答案是最后的right。
然而这道题我一开始写成left=mid就超时了,改成left=mid+1就过了。我也不知道为什么,现在还没想明白。但是我似乎每道二分都超时了。

#include<stdio.h>
int money[100010],n,m;

int check(int mid)
{
    int sum=0,month=1;
    for(int i=1;i<=n;i++)
    {
        sum+=money[i];
        if(sum>mid)
        {
            month++;
            sum=money[i];
        }
        if(month>m) return 1;
    }
    return 0;
}

int main()
{
    int left=0,right=0,mid;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&money[i]);
        money[i]>left?left=money[i]:left=left;
        right+=money[i];
    }
    while(left<right)
    {
        mid=(left+right)/2;
        if(check(mid)==1)
            left=mid+1;
        else
            right=mid;
    }
    printf("%d\n",right);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值