//并查集//poj2236//Wireless Network------四M

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.
The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

解题思路:
其实这道题基本上也可以用并查集的套路做,唯一的区别就是Union的两个电脑间的距离必须小于d且必须都是修好的。一开始我还在想有什么快速的方法,后来发现这道题的时限是10s……所以每修好一台电脑,都要遍历一遍其他电脑,看两台是否能Union在一起。如果两台电脑的父结点相等,那就可以相互联络。

#include<stdio.h>
#include<memory.h>

int n,d;
int x[1005],y[1005],father[1005],good[1005];

void init()
{
    for(int i=1;i<=n;i++)
    {
        father[i]=-1;
        good[i]=0;
    }
}

int find(int n)
{
    if(father[n]==-1)
        return n;
    else
    {
        father[n]=find(father[n]);
        return father[n];
    }
}

void Union(int a,int b)
{
    a=find(a);
    b=find(b);
    if(a!=b)
    {
        father[a]=b;
    }
}

int main()
{
    char tmp;
    int c,p,q;
    scanf("%d%d",&n,&d);
    init();
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&x[i],&y[i]);
    }
    getchar();
    while(scanf("%c",&tmp)!=EOF)
    {
        if(tmp=='O')
        {
            scanf("%d",&c);
            if(good[c]==1) continue;
            else good[c]=1;
            for(int i=1;i<=n;i++)
            {
                if((i!=c)&&(good[i]==1)&&((x[i]-x[c])*(x[i]-x[c])+(y[i]-y[c])*(y[i]-y[c])<=d*d))
                {
                    Union(i,c);
                }
            }
        }
        else
        {
            scanf("%d%d",&p,&q);
            if(find(p)==find(q))
            {
                printf("SUCCESS\n");
            }
            else
            {
                printf("FAIL\n");
            }
        }
        getchar();
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值