HDU - 3652 B-number 数位DP(记忆化搜索)

B-number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9200    Accepted Submission(s): 5481


 

Problem Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

 

 

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

 

 

Output

Print each answer in a single line.

 

 

Sample Input

 

13 100 200 1000

 

 

Sample Output

 

1 1 2 2

 

题意:找出1到n中即含13而且能整除13的数字的个数。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
#include<map>
#include<set>
#include<cmath>
#include<cctype>
#include<ctime>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
typedef long long ll;
typedef unsigned long long ull;

using namespace std;

int a[25];
ll dp[25][25][3];

ll dfs(int len,int modd,int cnt,bool limit)
{
	if(len==-1) return (cnt==2)&&(modd==0);
	if(!limit&&dp[len][modd][cnt]!=-1) return dp[len][modd][cnt];
	ll ans=0;
	int up=limit?a[len]:9;
	for(int i=0;i<=up;i++)
	{
		int mod=(modd*10+i)%13;
		int ccnt=cnt;
		if(cnt==0&&i==1) ccnt=1;
		else if(cnt==1&&i==3) ccnt=2;
		else if(cnt==1&&i!=1) ccnt=0;
		ans+=dfs(len-1,mod,ccnt,i==a[len]&&limit);
	}
	if(!limit) dp[len][modd][cnt]=ans;
	return ans;
}

ll fun(int x)
{
	int len=0;
	while(x)
	{
		a[len++]=x%10;
		x/=10;
	}
	return dfs(len-1,0,0,1);
}

int main()
{
    int n;
    while(cin>>n)
    {
    	memset(dp,-1,sizeof(dp));
    	cout<<fun(n)<<endl;
	}
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值