题目1023:EXCEL排序

题目1023:EXCEL排序

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:23632

解决:5281

题目描述:
    Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。
    对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3 
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
输入:

    测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (N<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有N行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。

输出:
    对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3 
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
样例输入:
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
0 0
样例输出:
Case 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Case 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Case 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
来源:
2007年浙江大学计算机及软件工程研究生机试真题
答疑:
解题遇到问题?分享解题心得?讨论本题请访问: http://t.jobdu.com/thread-7747-1-1.html

思路:就是简单的排序的应用。
#include <iostream>
#include <algorithm>
#include <string>
#include <fstream>
using namespace std;
struct Student
{
	string ID;
	string name;
	int grade;
}student[100001];
bool cmp1(const Student &a,const Student &b)
{
	return a.ID.compare(b.ID)<0;
}
bool cmp2(const Student &a,const Student &b)
{
	if(a.name.compare(b.name)!=0)
	return a.name.compare(b.name)<0;
	else return a.ID.compare(b.ID)<0;
}
bool cmp3(const Student &a,const Student &b)
{
	if(a.grade!=b.grade)
	return a.grade<b.grade;
	else return a.ID.compare(b.ID)<0;
}
int main()
{
	ifstream in;
	in.open("1.txt");
	int n,c;
	int count=1;
	while(in>>n && n!=0)
	{
		in>>c; 
		for(int i=0;i<n;i++)
		in>>student[i].ID>>student[i].name>>student[i].grade;
		if(c==1)
		{
			sort(student,student+n,cmp1);
			cout<<"Case "<<count<<":"<<endl;
			for(int i=0;i<n;i++)
			cout<<student[i].ID<<" "<<student[i].name<<" "<<student[i].grade<<endl; 
			++count;
		}else if(c==2)
		{
			sort(student,student+n,cmp2);
			cout<<"Case "<<count<<":"<<endl;
			for(int i=0;i<n;i++)
			cout<<student[i].ID<<" "<<student[i].name<<" "<<student[i].grade<<endl; 
			++count;
		}else if(c==3)
		{
			sort(student,student+n,cmp3);
			cout<<"Case "<<count<<":"<<endl;
			for(int i=0;i<n;i++)
			cout<<student[i].ID<<" "<<student[i].name<<" "<<student[i].grade<<endl; 
			++count;
		}
	}
	return 0;
} 

(2)附上别人的不同代码

//Asimple
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <string>
#include <queue>
#define INF 100000
using namespace std;
const int maxn = 100005;
typedef long long ll ;
int n, m, num = 1;

typedef struct node{
    char no[10];
    char name[10];
    int grade;
}im;

im st[maxn];

bool cmp1(const node& a, const node& b){
    return strcmp(a.no,b.no)<0;
}

bool cmp2(const node& a,const node& b){
    if( strcmp(a.name,b.name) != 0){
        return strcmp(a.name, b.name)<0;
    } else {
        return strcmp(a.no, b.no)<0;
    }
}

bool cmp3(const node& a,const node& b){
    if( a.grade != b.grade ){
        return a.grade < b.grade ;
    } else {
        return strcmp(a.no,b.no)<0;
    }
}

int main(){
    while( scanf("%d %d",&n,&m) && ( n + m ) ){
        for(int i=0; i<n; i++){
            scanf("%s %s %d",st[i].no,st[i].name,&st[i].grade);
        }
        switch(m){
            case 1:
                sort(st,st+n,cmp1);
                break;
            case 2:
                sort(st,st+n,cmp2);
                break;
            case 3:
                sort(st,st+n,cmp3);
                break;
        }
        printf("Case %d:\n",num);
        num ++ ;
        for(int i=0; i<n; i++){
            printf("%s %s %d\n",st[i].no,st[i].name,st[i].grade);
        }
    }
    return 0;
}

(3)这个想法也很好
#include <string.h>  
#include <stdio.h>  
#include <algorithm>  
using namespace std;  
#define MAX 100001  
struct Student{  
    char id[7];  
    char name[9];  
    int score;   
};  
Student student[MAX];  
bool compare1(Student x, Student y){  
     return  strcmp(x.id,y.id)<0;  
}  
bool compare2(Student x, Student y){  
     return  strcmp(x.name,y.name)<0;  
}  
bool compare3(Student x, Student y){  
     return  x.score<y.score;  
}  
int main(){  
      
    int N,C,i;  
    int cnt = 1;  
    while(scanf("%d %d",&N,&C)!=EOF){  
        if(N==0) break;  
        for(i = 0 ;i < N ; i++)   scanf("%s %s %d",student[i].id,student[i].name,&student[i].score);       
        sort(student,student+N,compare1);          
        switch(C){  
            case 1:break;  
            case 2:stable_sort(student,student+N,compare2) ;break;  
            case 3:stable_sort(student,student+N,compare3) ;break;           
        }  
        printf("Case %d:\n",cnt++);  
        for(i = 0 ;i < N ; i++)   printf("%s %s %d\n",student[i].id,student[i].name,student[i].score);  
    }  
    return 0;      
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值