题目1039:Zero-complexity Transposition

题目1039:Zero-complexity Transposition

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:3996

解决:1601

题目描述:

You are given a sequence of integer numbers. Zero-complexity transposition of the sequence is the reverse of this sequence. Your task is to write a program that prints zero-complexity transposition of the given sequence.

输入:

For each case, the first line of the input file contains one integer n-length of the sequence (0 < n ≤ 10 000). The second line contains n integers numbers-a1, a2, …, an (-1 000 000 000 000 000 ≤ ai ≤ 1 000 000 000 000 000).

输出:

For each case, on the first line of the output file print the sequence in the reverse order.

样例输入:
5
-3 4 6 -8 9
样例输出:
9 -8 6 4 -3
来源:
2007年上海交通大学计算机研究生机试真题
答疑:
解题遇到问题?分享解题心得?讨论本题请访问: http://t.jobdu.com/thread-7763-1-1.html

思路:每个数字当成一个字符串来处理就是很简单
#include <iostream>
#include <fstream>
using namespace std;
string str[10001];
int main()
{
    ifstream in;
    in.open("2.txt");
    int n;
    while(in>>n)
    {
        for(int i=0;i<n;++i)
            in>>str[i];
        for(int i=n-1;i>0;--i)
            cout<<str[i]<<" ";
        cout<<str[0]<<endl;
    }
    return 0;
}

(2)整数方法
#include<stdio.h>
int main()
{
    int i,n;
    long long a[1000];
    while(scanf("%d",&n)!=EOF){
        for(i=0;i<n;i++) scanf("%lld",&a[i]);
        for(i=n-1;i>0;i--) printf("%lld ",a[i]);
        printf("%lld\n",a[0]);                       
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值