最大连续子序列
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 26280 Accepted Submission(s): 11816
Problem Description
给定K个整数的序列{ N1, N2, ..., NK },其任意连续子序列可表示为{ Ni, Ni+1, ...,
Nj },其中 1 <= i <= j <= K。最大连续子序列是所有连续子序列中元素和最大的一个,
例如给定序列{ -2, 11, -4, 13, -5, -2 },其最大连续子序列为{ 11, -4, 13 },最大和
为20。
在今年的数据结构考卷中,要求编写程序得到最大和,现在增加一个要求,即还需要输出该
子序列的第一个和最后一个元素。
Nj },其中 1 <= i <= j <= K。最大连续子序列是所有连续子序列中元素和最大的一个,
例如给定序列{ -2, 11, -4, 13, -5, -2 },其最大连续子序列为{ 11, -4, 13 },最大和
为20。
在今年的数据结构考卷中,要求编写程序得到最大和,现在增加一个要求,即还需要输出该
子序列的第一个和最后一个元素。
Input
测试输入包含若干测试用例,每个测试用例占2行,第1行给出正整数K( < 10000 ),第2行给出K个整数,中间用空格分隔。当K为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最大和、最大连续子序列的第一个和最后一个元
素,中间用空格分隔。如果最大连续子序列不唯一,则输出序号i和j最小的那个(如输入样例的第2、3组)。若所有K个元素都是负数,则定义其最大和为0,输出整个序列的首尾元素。
素,中间用空格分隔。如果最大连续子序列不唯一,则输出序号i和j最小的那个(如输入样例的第2、3组)。若所有K个元素都是负数,则定义其最大和为0,输出整个序列的首尾元素。
Sample Input
6 -2 11 -4 13 -5 -2 10 -10 1 2 3 4 -5 -23 3 7 -21 6 5 -8 3 2 5 0 1 10 3 -1 -5 -2 3 -1 0 -2 0
Sample Output
20 11 13 10 1 4 10 3 5 10 10 10 0 -1 -2 0 0 0Huge input, scanf is recommended.HintHint
找到最大连续子序列:
从开头开始把和设为1,与后面每一个数累加,
只要与前面和相加不为负,
后面就可能存在某一数在顺着这一序列而得到最大,故保留每一个正数和并判断是否大于最大
若相加和为负,
重置当前和为0,简单来说就是重新开始计数。
小问题:
找到起始点及终止点
终止点:对于这道题终止点相对大的方向易于查找,但存在当前几个元素都为负,max=0的局面,所以要试图找到第一个非负点(或最后一点)为终止
起始点:我是用终止点反向累加得到起始点
#include<iostream>
using namespace std;
int main()
{
int n,a[10001],k,b[100001],max,i,j,sum,flag;
//n:序列长度 a:存放输入序列 k:计数 b:记录到当前位置的可行非负和
//max:最大和 i:开头 j:结尾 sum:从j找i时的和 flag:找到第一个非负元素的辅助标志
while(cin>>n)
{
if(n==0)
break;
for(k=0;k<n;k++)
cin>>a[k];
max=b[0]=0;
i=j=0;
flag=1;
for(k=0;k<n;k++)
{
if(b[k-1]+a[k]>0)
{
b[k]=b[k-1]+a[k];
if(b[k]>max)
{
max=b[k];
j=k;
}
}
else
{
b[k]=0;
if(flag)//flag表示前面没有非负
{
if(a[k]<0)
j=k;
else if(a[k]==0)//当非负时
{
j=k;
flag=0;
}
}
}
}
sum=0;
for(k=j;k>=0;k--)//由终点往前查找
{
sum+=a[k];
if(sum==max&&a[k-1]!=0&&k-1>=0)
{
i=k;
break;
}
}
cout<<max<<" "<<a[i]<<" "<<a[j]<<endl;
}
return 0;
}
附:讲道理上述找到边界的算法纯属脑残。。。
下面是基本一样的题:
Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 207182 Accepted Submission(s): 48449
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
代码如下:(方法直接写在程序里)
#include<iostream>
using namespace std;
int main()
{
int n,m,k,i,t,a[100000],l,r,templ,tempr;
cin>>m;
for(t=0;t<m;t++)
{
cin>>n;
for(k=0;k<n;k++)
cin>>a[k];
int max=a[0],sum=0;
i=0;
for(k=0;k<n;k++)
{
sum+=a[k];
if(sum>=max)
{
max=sum;
l=i;//将暂存的i赋给左
r=k;//右端直接赋值
}
if(sum<0)
{
sum=0;
i=k+1;//可能是左边界,暂存
}
}
cout<<"Case "<<t+1<<":"<<endl;
cout<<max<<" "<<l+1<<" "<<r+1<<endl;
if(t<m-1)cout<<endl;
}
return 0;
}
是不是简单快捷很多
思考,改进ing