1075 PAT Judge (25)

1075. PAT Judge (25)

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

/*排序问题 不难 但要细心
输入: 
n为用户数,k为问题数,m为提交数 
k个问题的满分值 
m次提交  格式:用户id,题号,得分 
输出:
按照总分降序排列,如果总分相同按照拿到满分值的题目数降序排列,如果还相同,则按照id升序排列 

结构体中subflag[6]标记每道题目是否提交 ,flag标记该用户有无提交or能否能过编译 
*/

#include<stdio.h>
#include<algorithm>
using namespace std;
int n,k,m;
struct node{
	int id;
	int rank;
	int score[6];
	int subflag[6];
	int sumscore;
	int flag;
	int perfect;
};
bool comp(node a, node b){
	if(a.sumscore!=b.sumscore)return a.sumscore>b.sumscore;
	else if(a.perfect!=b.perfect)return a.perfect>b.perfect;
	else return a.id<b.id;
}
int main(){
	int i,j;
	scanf("%d %d %d",&n,&k,&m);
	struct node stu[n+1];
	int fullmark[k+1];
	for(i=1;i<=k;i++){
		scanf("%d",&fullmark[i]);
	}
	for(i=1;i<=n;i++){
		stu[i].flag=0;
		stu[i].sumscore=0;
		stu[i].perfect=0;
		stu[i].id=i;//保留id 
		for(j=1;j<=k;j++){
			stu[i].score[j]=0;
			stu[i].subflag[j]=0;
		}
	}
	int tempid,problem,tempscore;
	for(i=0;i<m;i++){
		scanf("%d %d %d",&tempid,&problem,&tempscore);
		stu[tempid].subflag[problem]=1;//该题目有提交 
		if(tempscore>stu[tempid].score[problem]){//更新得分 
			stu[tempid].sumscore=stu[tempid].sumscore+tempscore-stu[tempid].score[problem];
			stu[tempid].score[problem]=tempscore;
		}
		if(tempscore!=-1){
			stu[tempid].flag=1;//该用户有提交并且能通过编译 
		}
	}
	for(i=1;i<=n;i++){
		for(j=1;j<=k;j++){
			if(stu[i].score[j]==fullmark[j]){
				stu[i].perfect++;//最后一个测试点存在一道题目多次满分情况 ,只能算一次! 
			}
		}
	}
	sort(stu+1,stu+1+n,comp);
	stu[1].rank=1;
	for(i=2;i<=n;i++){
		stu[i].rank=i;
		if(stu[i].sumscore==stu[i-1].sumscore){
			stu[i].rank=stu[i-1].rank;
		}
	}
	for(i=1;i<=n;i++){
		if(stu[i].flag){
			printf("%d %05d %d",stu[i].rank,stu[i].id,stu[i].sumscore);
			for(j=1;j<=k;j++){
				if(stu[i].subflag[j]==0){
					printf(" -");
				}
				else{
					printf(" %d",stu[i].score[j]);
				}
			}
			printf("\n");
		}
	}
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值