03-树3 Tree Traversals Again (25分)


An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 3030) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to NN). Then 2N2Nlines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

这题参照王道考研机试指南P53。

push为前序,pop为中序,然后建树.后序输出


#include <stack>//模拟 王道考研机试指南 
#include <string.h>
#include<stdio.h>
using namespace std;
typedef struct Node *node;
struct Node{
	node left;
	node right;
	int num;
}tree[30];
int count=0,cou3=0;
int qx[30],zx[30],hx[30];
node chuli(int s1,int e1,int s2,int e2){
	tree[count].left=tree[count].right=NULL;
	tree[count].num=qx[s1];
	node head=&tree[count++];
	int root,i;
	for(i=s2;i<=e2;i++){
		if(zx[i]==qx[s1]){
			root=i;break;
		}
	}
	if(root!=s2){
		head->left=chuli(s1+1,root-s2+s1,s2,root-1);
	}
	if(e2!=root){
		head->right=chuli(root-s2+s1+1,e1,root+1,e2);
	}
	return head;
}
void post(node T){
	if(T){		
		post(T->left);
		post(T->right);
		hx[cou3++]=T->num;
	}
}
int main(){
	int n,i;
	scanf("%d",&n);
	int cou1=0,cou2=0;
	char str[10];
	int temp;
	stack<int>s;
	for(i=0;i<2*n;i++){		
		scanf("%s",str);
		if(strlen(str)==4){
			scanf("%d",&temp);
			qx[cou1++]=temp;
			s.push(temp);
		}
		else{
			zx[cou2++]=s.top();
			s.pop();
		}
	}
	node head=chuli(0,n-1,0,n-1);
	post(head);
	printf("%d",hx[0]);
	for(i=1;i<n;i++){
		printf(" %d",hx[i]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值