1107. Social Clusters (30)


时间限制
1000 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] ... hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1

参照算法笔记P311.
没有好好理解并查集。

这里应该考虑爱好相同时,把人并起来,而不是爱好。


#include<stdio.h>
#include<algorithm>
using namespace std;
bool comp(int a,int b){
	return a>b;
}
int course[1010]={0};
int tree[1010];
int cnt[1010]={0};
int findroot(int x){
	if(tree[x]==-1)return x;
	return tree[x]=findroot(tree[x]);
}
void init(int n){
	int i;
	for(i=1;i<=n;i++){
		tree[i]=-1;
	}
}
int main(){
	int n,i,j,k,temp;
	scanf("%d",&n);
	init(n);
	for(i=1;i<=n;i++){
		scanf("%d:",&k);
		for(j=0;j<k;j++){
			scanf("%d",&temp);
			if(course[temp]==0){
				course[temp]=i;
			}
			else{
				int a=findroot(i);
				int b=findroot(course[temp]);
				if(a!=b){
					tree[a]=b;
				}
			}
		}
	}
	int cou=0;
	for(i=1;i<=n;i++){
		int index=findroot(i);
		cnt[index]++;
		if(tree[i]==-1){
			cou++;
		}		
	}
	sort(cnt+1,cnt+1+n,comp);
	printf("%d\n",cou);
	printf("%d",cnt[1]);
	for(i=2;i<=cou;i++){
		printf(" %d",cnt[i]);
	}
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值