PAT 甲级 A1107 Social Clusters

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki​: hi​[1] hi​[2] ... hi​[Ki​]

where Ki​ (>0) is the number of hobbies, and hi​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

题意:

有n给人物,遍历这n个人物,每个人物有k项喜欢得运动,在:后面引出,如果这些人喜欢的活动有交集,则这些人物在一个社交圈内,问有几个社交圈?每个社交圈内有多少人,按从大到小的排列顺序输出;

思路:
找元素有关系的集合,用并查集,但是这个题目给的不是直接的人物和人物的关系,而是人和喜欢活动的关系,因此要将第一个喜欢该活动的人记录下来作为人和喜欢活动的树的根节点,某个人可以通过这个活动树可以找到人和人之间的关系。

代码:
 

//该题没有直接给出人物关系,而是通过活动间接找到人物关系; 
//不是通过人与人之间的直接关系,而是通过喜欢的活动而实现的间接关系; 
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 1010;
int course[maxn] = {0};
int father[maxn] = {0};
int isroot[maxn] = {0};
int n, m, k, h;

bool cmp(int a, int b) {
	return a > b;
	
}

int findFather(int x) {//找到父节点才能判断是否在一个集合内; 
	if(father[x] == x) return x;
	else {//递归找根节点,路径压缩; 
		int f = findFather(father[x]);
		father[x] = f;
		return f;
	}
}

void Union(int a, int b) {
	int fa = findFather(a);
	int fb = findFather(b);
	if(fa != fb){
		father[fb] = fa;
	}
}

void init(int n) {
	for(int i = 1; i <= n; i++){
		father[i] = i;//初始化,使得每个结点都暂时拥有自己得一个集合; 
	}
}

int main ( ){
	scanf("%d", &n);//有n个人
	init(n);//初始化,保证每个集合至少有一个人; 
	for(int i = 1; i <= n; i++) {
		scanf("%d:", &k);//这个人有k项喜欢的活动; 
		for(int j = 0; j < k; j++) {
			scanf("%d", &h);//喜欢的活动h;
			if(course[h] == 0) {
				course[h] = i;//通过活动间接来建立关系,因此要建立一颗人物与活动的关系树; 
			}
			Union(i, findFather(course[h]));//通过人物间接找到人物关系; 
		} 
	}
	for(int i = 1; i <= n;i++) {//遍历n个人物,统计每个集合内人的个数; 
		isroot[findFather(i)]++;
	}
	int ans=0;
	for(int i = 1; i <= n; i++) {
		if(isroot[i] != 0) ans++;
	}
	printf("%d\n", ans);
	sort(isroot + 1, isroot + 1+n, cmp);
	for(int i = 1; i<=ans; i++) {
		printf("%d", isroot[i]);
		if(i != ans) printf(" ");
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值