1072. Gas Station (30)

1072. Gas Station (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2
Sample Output 1:
G1
2.0 3.3
Sample Input 2:
2 1 2 10
1 G1 9
2 G1 20
Sample Output 2:
No Solution

这题题目没看懂,参照上机指南。


选出一个站,使所有的房子都在站的范围内,并且离站最近的距离越大越好。如果最近距离相同,则站到所有房子的距离和越小越好。


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define inf 999999999
int n,m,k,ds;
int adj[1020][1020];
int mark[1020];
int dis[1020];
void init(){
	int i,j;
	for(i=1;i<=n+m;i++){
		dis[i]=inf;
		for(j=1;j<=n+m;j++){
			adj[i][j]=inf;
		}
		adj[i][i]=0;
	}
}
void init2(){
	int i,j;
	for(i=1;i<=n+m;i++){
		dis[i]=inf;
		mark[i]=0;
	}
}
void dijkstra(int s){	
	mark[s]=1;
	dis[s]=0;
	int i,newp=s;
	while(1){
		for(i=1;i<=n+m;i++){
			if(mark[i]==0&&adj[newp][i]<inf){
				if(dis[i]>dis[newp]+adj[newp][i]){
					dis[i]=dis[newp]+adj[newp][i];
				}
			}
		}
		int min=inf;
		for(i=1;i<=m+n;i++){
			if(mark[i]==0&&dis[i]<inf){
				if(dis[i]<min){
					min=dis[i];
					newp=i;
				}
			}
		}
		mark[newp]=1;
		if(min==inf){
			break;
		}
	}
	
}
int main(){
	int i,j,distance,c1,c2;
	char s1[5],s2[5];
	scanf("%d %d %d %d",&n,&m,&k,&ds);
	init();	
	for(i=1;i<=k;i++){
		scanf("%s %s %d",s1,s2,&distance);
		if(s1[0]=='G'){
			if(strlen(s1)==2){
				c1=n+s1[1]-'0';
			}
			else{
				c1=n+10;
			}
		}
		else{
			c1=atoi(s1);
		}
		if(s2[0]=='G'){
			if(strlen(s2)==2){
				c2=n+s2[1]-'0';
			}
			else{
				c2=n+10;
			}
		}
		else{
			c2=atoi(s2);
		}
		adj[c1][c2]=adj[c2][c1]=distance;
	}
	int exist=0,flag,maxdis,mindis,sumdis,minsumdis,maxindex;
	for(i=1;i<=m;i++){
		sumdis=0;
		mindis=inf;
		flag=1;
		init2();
		dijkstra(n+i);
		for(j=1;j<=n;j++){
			if(dis[j]>ds){
				flag=0;break;
			}
			if(dis[j]<mindis){
				mindis=dis[j];
			}
			sumdis=sumdis+dis[j]; 
		}
		if(flag==0){
			continue;
		}
		exist=1;
		if(mindis>maxdis){
			maxdis=mindis;
			maxindex=i;
			minsumdis=sumdis;
		}
		else if(mindis==maxdis&&sumdis<minsumdis){
			minsumdis=sumdis;
			maxindex=i;
		}
	}
	if(exist==0){
		printf("No Solution");
	}
	else{
		printf("G%d\n",maxindex);
		printf("%.1lf %.1lf",(double)maxdis,(double)minsumdis/n);
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip 【备注】 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用!有问题请及时沟通交流。 2、适用人群:计算机相关专业(如计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网、自动化、电子信息等)在校学生、专业老师或者企业员工下载使用。 3、用途:项目具有较高的学习借鉴价值,不仅适用于小白学习入门进阶。也可作为毕设项目、课程设计、大作业、初期项目立项演示等。 4、如果基础还行,或热爱钻研,亦可在此项目代码基础上进行修改添加,实现其他不同功能。 欢迎下载!欢迎交流学习!不清楚的可以私信问我! 毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip
用c++解决pipeline system consists of N transfer station, some of which are connected by pipelines. For each of M pipelines the numbers of stations A[i] and B[i], which are connected by this pipeline, and its profitability C[i] are known. A profitability of a pipeline is an amount of dollars, which will be daily yielded in taxes by transferring the gas through this pipeline. Each two stations are connected by not more than one pipeline. The system was built by Soviet engineers, who knew exactly, that the gas was transferred from Ukrainian gas fields to Siberia and not the reverse. That is why the pipelines are unidirectional, i.e. each pipeline allows gas transfer from the station number A[i] to the station number B[i] only. More over, if it is possible to transfer the gas from the station X to the station Y (perhaps, through some intermediate stations), then the reverse transfer from Y to X is impossible. It is known that the gas arrives to the starting station number S and should be dispatched to the buyers on the final station number F. The President ordered the Government to find a route (i.e. a linear sequence of stations which are connected by pipelines) to transfer the gas from the starting to the final station. A profitability of this route should be maximal. A profitability of a route is a total profitability of its pipelines. Unfortunately, the President did not consider that some pipelines ceased to exist long ago, and, as a result, the gas transfer between the starting and the final stations may appear to be impossible... Input The first line contains the integer numbers N (2 ≤ N ≤ 500) and M (0 ≤ M ≤ 124750). Each of the next M lines contains the integer numbers A[i], B[i] (1 ≤ A[i], B[i] ≤ N) and C[i] (1 ≤ C[i] ≤ 10000) for the corresponding pipeline. The last line contains the integer numbers S and F (1 ≤ S, F ≤ N; S ≠ F). Output If the desired route exists, you should output its profitability. Otherwise you should output "No solution".
05-28
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值