【PAT刷题甲级】1072.Gas Station

1072 Gas Station (30 分)

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10 ^3 ), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10 ^4 ), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1

G1
2.0 3.3

Sample Input 2

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2

No Solution

题意

对于任意加油站点,找出离其最近的住宅区,选出两者之间的距离最大的加油站点,并且要保证该加油站点与所有的住宅区都在服务范围内。不止一个加油站点,选择平均距离最小的,若平均距离也相同,选择序号最小的。(Dijkstra)
PS:一开始题目没看懂,还是参考了柳神的博客才明白题目是怎么回事,英语不过关,然后我又又又犯了个致命的错误,在写Dijkstra时将vis[u]=true;写成了vis[u]==true; 导致我答案一直不对。
太粗心了太粗心了!

代码

#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#include <cmath>
using namespace std;
int n,m,k,ds,G[1020][1020];
int d[1020];
bool vis[1020];
const int inf=0x3fffffff;
void Dijkstra(int s) {
	fill(d,d+1020,inf);
	fill(vis,vis+1020,false);
	d[s]=0;
	for(int i=1; i<=n+m; i++) {
		int u=-1,minn=inf;
		for(int j=1; j<=n+m; j++) {
			if(vis[j]==false && d[j]<minn) {
				u=j;
				minn=d[j];
			}
		}
		if(u==-1)	return;
		vis[u]=true;		//千万别写成vis[u]==true!!!
		for(int v=1; v<=n+m; v++) {
			if(vis[v]==false && G[u][v]!=inf && d[u]+G[u][v]<d[v]) {
				d[v]=d[u]+G[u][v];
			}
		}
	}
}
int main() {
	scanf("%d%d%d%d",&n,&m,&k,&ds);
	fill(G[0],G[0]+1020*1020,inf);
	string a,b;
	for(int i=0; i<k; i++) {
		int dis;
		cin >> a >> b >> dis;
		int p1,p2;
		if(a[0]=='G')
			p1=n+stoi(a.substr(1));
		else
			p1=stoi(a);
		if(b[0]=='G')
			p2=n+stoi(b.substr(1));
		else
			p2=stoi(b);
		G[p1][p2]=G[p2][p1]=dis;
	}
	int pos=-1,ans=-1;					//选择的加油站点序号,最小距离
	double avgnow=inf;					//平均距离
	for(int i=n+1; i<=n+m; i++) {		//可以保证序号为最小值
		Dijkstra(i);
		double avgr=0;
		int nearest=inf;				//离站点最近的住宅区nearest
		for(int j=1; j<=n; j++) {
			if(d[j]>ds) {
				nearest=-1;
				break;
			}
			if(d[j]<nearest)	nearest=d[j];
			avgr += 1.0*d[j];
		}
		if(nearest==-1)	continue;
		avgr=avgr/n;
		if(nearest>ans) {
			ans=nearest;
			pos=i;
			avgnow=avgr;
		} else if(nearest==ans && avgr<avgnow) {
			pos=i;
			avgnow=avgr;
		}
	}
	if(pos!=-1) {
		printf("G%d\n",pos-n);
		printf("%.1lf %.1lf",(double)ans,round(avgnow*10)/10);
	} else {
		printf("No Solution");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值