1140. Look-and-say Sequence (20)

1140. Look-and-say Sequence (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:
1 8
Sample Output:
1123123111

2018.3.18 PAT 94~

这题开始读题目读了10分钟。。。没看懂,先做了后面3题,回来在做了这题。在这道题目上差不多花了1小时。。。

输入样例,除了第一个,其他2个2个看。第一个只有D,所以第二个D1,这里D表示字符,1表示D的个数。第三个D1 11

,D表示字符,紧跟的1表示D的个数,然后下一个1表示字符1,紧跟后面的1表示字符1的个数...


为什么考试最后一点超时,现在提交就过了呢。。。虽然是345ms。。。

#include<stdio.h>
#include<string>
#include<iostream>
using namespace std;
char change(int x){//数字字符与字符阿斯克吗相差 48 
	return x+48;
}
int main(){
	int n,i,j,cou;
	string ans;
	cin>>ans>>n;
	if(n==1){
		cout<<ans;return 0;
	}
	n--;
	while(n--){
		string tmp="";
		for(i=0;i<ans.size();i++){
			tmp=tmp+ans[i];
			cou=1;
			char c=ans[i];
			for(j=i+1;j<ans.size();j++){
				if(ans[j]!=c){
					break;
				}
				else{
					cou++;//计算连续相同的有几个 
				}
			}
			i=i+cou-1;//跳过连续相同的 
			char aa=change(cou) ;//把个数转换为字符 
			tmp=tmp+aa;
		}
		ans=tmp;
	}
	cout<<ans;
}

靴习一个  to_string

记得在DEV-工具-编译选项-编译器-[勾选 编译时加入以下命令] 填入

  -std=c++11     (小写c)

#include<stdio.h>
#include<string>
#include<iostream>
using namespace std;
//char change(int x){//数字字符与字符阿斯克吗相差 48 
//	return x+48;
//}
int main(){
	int n,i,j,cou;
	string ans;
	cin>>ans>>n;
	if(n==1){
		cout<<ans;return 0;
	}
	n--;
	while(n--){
		string tmp="";
		for(i=0;i<ans.size();i++){
			tmp=tmp+ans[i];
			cou=1;
			char c=ans[i];
			for(j=i+1;j<ans.size();j++){
				if(ans[j]!=c){
					break;
				}
				else{
					cou++;//计算连续相同的有几个 
				}
			}
			i=i+cou-1;//跳过连续相同的 
//			char aa=change(cou) ;//把个数转换为字符 
			tmp=tmp+to_string(cou);//aa; 
		}
		ans=tmp;
	}
	cout<<ans;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值