jzxx2914Paired Up(成对)

题目描述
Farmer John finds that his cows are each easier to milk when they have another cow nearby for moral support. He therefore wants to take his MM cows (M≤1,000,000,000, M even) and partition them into M/2 pairs. Each pair of cows will then be ushered off to a separate stall in the barn for milking. The milking in each of these M/2 stalls will take place simultaneously.
To make matters a bit complicated, each of Farmer John’s cows has a different milk output. If cows of milk outputs A and B are paired up, then it takes a total of A+B units of time to milk them both.
Please help Farmer John determine the minimum possible amount of time the entire milking process will take to complete, assuming he pairs the cows up in the best possible way.
John有n种牛(n<=100000),每种牛有数量x与时间y,牛的总数为m,要将m头牛分为m/2对,每对的时间花费为两牛时间之和,问最大的那对的最小值(m<=1e9 y<=1e9)

输入
The first line of input contains N (1≤N≤100,000). Each of the next N lines contains two integers x and y, indicating that FJ has x cows each with milk output y (1≤y≤1,000,000,000). The sum of the xx’s is M, the total number of cows.

输入的第一行为N(1<=n<=100000)。

后面N行每行包含两个整数x和y。所有X的总和是M。

输出
Print out the minimum amount of time it takes FJ’s cows to be milked, assuming they are optimally paired up.

打印出FJ的奶牛挤奶所需的最短时间,假设它们是最佳配对。

样例输入
3
1 8
2 5
1 2

样例输出
10

提示
Here, if the cows with outputs 8+2 are paired up, and those with outputs 5+5 are paired up, the both stalls take 10 units of time for milking. Since milking takes place simultaneously, the entire process would therefore complete after 10 units of time. Any other pairing would be sub-optimal, resulting in a stall taking more than 10 units of time to milk.

来源/分类
USACO 2017 Open Silver

传送门

满分代码:
#include <iostream>
#include <fstream>
#include <cmath>
#include <algorithm>
#include <vector>
using namespace std;
typedef pair<int,int> pii;
vector<pii> V;
int N;
int main(void) {
	cin >> N;
	for (int i=0; i<N; i++) {
		int x, y;
		cin >> x >> y;
		V.push_back(pii(y,x));
	}
	sort(V.begin(), V.end());
	int M = 0, i=0, j=N-1;
	while (i <= j) {
		int x = min(V[i].second, V[j].second);
		if (i==j) x /= 2;
		M = max(M, V[i].first + V[j].first);
		V[i].second -= x;
		V[j].second -= x;
		if (V[i].second == 0) i++;
		if (V[j].second == 0) j--;
	}
	cout << M << "\n";
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值