Registration system

描述

A new e-mail service "Berlandesk" is going to be opened in Berland in the near future.

 The site administration wants to launch their project as soon as possible, that's why they ask you to help. You're suggested to implement the prototype of site registration system. The system should work on the following principle.Each time a new user wants to register, he sends to the system a request with his name.If such a name does not exist in the system database, it is inserted into the database, and 

the user gets the response OK, confirming the successful registration. If the name already exists in the system database, the system makes up a new user name, sends it to the user as a prompt and also inserts the prompt into the database. The new name is formed by the following rule. Numbers, starting with 1, are appended one after another to name (name1,name2, ...), among these numbers the least i is found so that namei does not yet exist in the database.



输入

The first line contains number n (1 ≤ n ≤ 105). The following n lines contain the requests to the system. Each request is a non-empty line, and consists of not more than 1000 characters, which are all lowercase Latin letters.


输出

Print n lines, which are system responses to the requests: OK in case of successful registration, or a prompt with a new name, if the requested name is already taken.


样例输入
4
abacaba
acaba
abacaba
acab


样例输出
OK
OK
abacaba1
OK



本题我琢磨怎么判断M[stringone]是否为空,如果为空,就让它为0,证明数据库里没有这个一样的信息,如果不为空,就让M[stringone]++,然后输出该字符串和它里面存的int类型的数,但我不知道怎么判断M中单独某一个string对应的int为空,所以我就把判断为空的定位1,然后判断是否为0,不为0 的话让它++,所以输出的时候得减1。



#include <iostream>

#include<stdio.h>
#include<string>
#include<map>
#include<string.h>
using namespace std;
int main()
{
    map<string,int> M;
    string s;
    int a;
    scanf("%d",&a);
    while(a--)
    {
        cin>>s;
        if(M[s]!=0)
        {
            M[s]++;
        }
        else
            M[s]=1;
        if(M[s]==1)
        {
            printf("OK\n");
        }
        else
        {
            cout<<s<<M[s]-1<<endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值