HDU 6168-Numbers

Numbers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 468    Accepted Submission(s): 245


题目链接:点击打开链接

Problem Description
zk has n numbers  a1,a2,...,an . For each (i,j) satisfying 1≤i<j≤n, zk generates a new number  (ai+aj) . These new numbers could make up a new sequence  b1b2,...,bn(n1)/2 .
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.
Can you help zk find out which n numbers were originally in a?
 

Input
Multiple test cases(not exceed 10).
For each test case:
The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
The second line contains m numbers, indicating the mixed sequence of a and b.
Each  ai  is in [1,10^9]
 

Output
For each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers  a1,a2,...,an(a1a2...an) . These are numbers in sequence a.
It's guaranteed that there is only one solution for each case.
 

Sample Input
6
2 2 2 4 4 4
21
1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11
 


Sample Output
3
2 2 2
6
1 2 3 4 5 6


题意:
如果我们现在有一个数组A【1····n】,那么我们每一次拿出两个数A【i】和A【j】(1≤i<j≤n),使得B【1····n(n-1)/2】=A【i】+A【j】,现在有人把两个数组合并到了一起,并且还是从小到大保证递增的,问我们数组A【】的信息。输出其大小和元素。


分析:
定义一个map数组,为了区别题意中的a数组和b数组,不至于算重,也不至于漏算,然后再分离出a数组。




#include<iostream>
#include<stdio.h>
#include<map>
using namespace std;
int s[125255];
int h[125255];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&s[i]);
        map<int,int> p;
        int m=0;
        for(int i=1;i<=n;i++)
        {
            if(p[s[i]]>0)
                p[s[i]]--;
            else
            {
                for(int j=0;j<m;j++)
                    p[s[i]+h[j]]++;
                h[m++]=s[i];
            }
        }
        printf("%d\n",m);
        for(int i=0;i<m;i++)
        {
            if(i==0)
                printf("%d",h[i]);
            else
                printf(" %d",h[i]);
        }
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值