HDU 1372-Knight Moves

Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12062    Accepted Submission(s): 7074


题目链接:点击打开链接


Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 
 

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.". 

Sample Input
e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6
 


Sample Output
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.



题意:
给出骑士的初始位置,和目标位置,问至少走多少步才能走到。a 到 h 代表 1---8 行,简单来说就相当于棋盘的位置,比如 e2代表第 5 行第二个位置,就这样。。。。。



分析:
坑啊,坑啊,坑啊!这题太坑了,蓝廋香菇。。。
这么一大堆读半天好像都没 get 到点,原来国际象棋中骑士的走法是 日 ,就是按马走日的走法移动,哎。。。
对于代码中的 1 出我要对有不理解的小伙伴解释一下,就是因为字符字母减去的是 a ,所以为了对应,字符数字减去的是 1 ,这样才会好控制,如果减去 0 ,就多出 1,不好控制。好啦,最近在练搜索题,感觉整个人都不好了。继续努力吧!



#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#define INF 0x3f3f3f3f
using namespace std;
int x1,x2,y1,y2;
int min1,vis[10][10];
int dir[][2]={{-1,2},{-2,1},{-2,-1},{-1,-2},{1,-2},{2,-1},{2,1},{1,2}};

void dfs(int a,int b,int cut)
{
    if(a==x2&&b==y2)
    {
        min1=min(cut,min1);///选择步数最少的一种走法
        return;
    }
    for(int i=0;i<8;i++)///往8个方向开始搜
    {
        int x=a+dir[i][0];
        int y=b+dir[i][1];
        if(x>=0&&x<8&&y>=0&&y<8)///如果没有出边界范围
        {
            if(vis[x][y]>cut)///用vis数组记录该最初位置走到该位置最少的步数
            {
                vis[x][y]=cut;
                dfs(x,y,cut+1);
            }
        }
    }
}

int main()
{
    string c1,c2;
    while(cin>>c1>>c2)
    {
        memset(vis,INF,sizeof(vis));
        x1=c1[0]-'a';
        y1=c1[1]-'1';///1
        x2=c2[0]-'a';
        y2=c2[1]-'1';
        min1=INF;
        dfs(x1,y1,0);///传起始位置以及步数
        cout<<"To get from "<<c1<<" to "<<c2<<" takes "<<min1<<" knight moves."<<endl;
    }
}




 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值