HDU 6205-card card card

card card cardTime Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2107    Accepted Submission(s): 931题目链接:点击打开链接Problem DescriptionAs a fan of Doudi...
摘要由CSDN通过智能技术生成

card card card

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2107    Accepted Submission(s): 931



题目链接:点击打开链接



Problem Description
As a fan of Doudizhu, WYJ likes collecting playing cards very much. 
One day, MJF takes a stack of cards and talks to him: let's play a game and if you win, you can get all these cards. MJF randomly assigns these cards into  n heaps, arranges in a row, and sets a value on each heap, which is called "penalty value".
Before the game starts, WYJ can move the foremost heap to the end any times. 
After that, WYJ takes the heap of cards one by one, each time he needs to move all cards of the current heap to his hands and face them up, then he turns over some cards and the number of cards he turned is equal to the  penaltyvalue.
If at one moment, the number of cards he holds which are face-up is less than the  penaltyvalue, then the game ends. And WYJ can get all the cards in his hands (both face-up and face-down).
Your task is to help WYJ maximize the number of cards he can get in the end.So he needs to decide how many heaps that he should move to the end before the game starts. Can you help him find the answer?
MJF also guarantees that the sum of all "penalty value" is exactly equal to the number of all cards.
 

Input
There are about  10 test cases ending up with EOF.
For each test case:
the first line is an integer  n ( 1n106), denoting  n heaps of cards;
next line contains  n integers, the  i th integer  ai ( 0ai1000) denoting there are  ai cards in  i th heap;
then the third line also contains  n integers, the  i th integer  bi ( 1bi1000) denoting the "penalty value" of  i th heap is  bi.
 

Output
For each test case, print only an integer, denoting the number of piles WYJ needs to move before the game starts. If there are multiple solutions, print the smallest one.
 

Sample Input
 
 
5 4 6 2 8 4 1 5 7 9 2
 

Sample Output
 
 
4
Hint
[pre] For the sample input: + If WYJ doesn't move the cards pile, when the game starts the state of cards is: 4 6 2 8 4 1 5 7 9 2 WYJ can take the first three piles of cards, and during the process, the number of face-up cards is 4-1+6-5+2-7. Then he can't pay the the "penalty value" of the third pile, the game ends. WYJ will get 12 cards. + If WYJ move the first four piles of cards to the end, when the game starts the state of cards is: 4 4 6 2 8 2 1 5 7 9 WYJ can take all the five piles of cards, and during the process, the number of face-up cards is 4-2+4-1+6-5+2-7+8-9. Then he takes all cards, the game ends. WYJ will get 24 cards. It can be improved that the answer is 4. **huge input, please use fastIO.** [/pre]


题意:

给你 n 堆卡片,每堆卡片设置一定的罚金,这 n 堆卡片都按照一定的顺序来排成行,你可以将第一堆卡片放到最后,(第一堆如果放到了最后,那么第二堆就成了第一堆,然后你也可以将其放到最后),游戏的规则是你可以将第一堆移动到最后,然后选取一堆开始哪走那堆卡片,但是对应的,你也应该留下对应的罚金数量,如果当你手上的卡片不足以支付罚金的数量时,你就输了,但是如果你赢了,你就可以哪走所有的卡片,让聪明的你求在你开始拿你选取的那堆卡片之前,你应该移动多少堆卡片(注意,这里所有罚金的数目等于所有卡片的数目)。


分析:

看着题臭长的英文,感觉好难的样子,其实都是表面现象,提醒自己以后读题要耐心看完,只要题意读懂了,基本就可以知道了,我们计算出第 i 堆卡片的数量减去对应的罚金的数量就是你能得到的卡片数量,只要让这些加和都大于0即可,也就是说把小于0的堆数都移到后面去。


#include <iostream>
#include<stdio.h>
#include<string.h>
#include<string>
#include<math.h>
using namespace std;

int s[1000005],h[1000005];

int main()
{
    int n,a;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&s[i]);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);
            h[i]=s[i]-a;
        }
        int sum=0,ans=0;
        for(int i=0;i<n;i++)
        {
            sum+=h[i];
            if(sum<0)
            {
                ans=i+1;///因为下标是从0开始的
                sum=0;///注意这里要置为0
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值