POJ - 1952 BUY LOW, BUY LOWER(最长下降子序列,计数)

BUY LOW, BUY LOWER

Description

The advice to "buy low" is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems' advice: 
                    "Buy low; buy lower"

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices. 

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy. 

Here is a list of stock prices: 
 Day   1  2  3  4  5  6  7  8  9 10 11 12

Price 68 69 54 64 68 64 70 67 78 62 98 87


The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is: 
Day    2  5  6 10

Price 69 68 64 62

Input

* Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given 

* Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers. 

Output

Two integers on a single line: 
* The length of the longest sequence of decreasing prices 
* The number of sequences that have this length (guaranteed to fit in 31 bits) 

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they "look the same" when the successive prices are compared. Thus, two different sequence of "buy" days could produce the same string of decreasing prices and be counted as only a single solution. 

Sample Input

12
68 69 54 64 68 64 70 67 78 62
98 87

Sample Output

4 2


题意:计算一串数字的最长下降子序列长度,并且计算可能性,不能有重复,如 321321,只能算一个321。


解题思路:第一次接触感觉好难,看了各种博客加上自己模拟了几次才看懂,很佩服他们到底是怎么想到的……dp部分直接套n^2的模板,重点是处理重复部分,这里我们再用一个数组sum[i]记录0~i这个区间内最长为dp[i]时的个数,在不考虑重复的情况下,会有转移方程if(dp[i]==dp[j]+1)sum[i]+=sum[j],if(dp[j]+1>dp[i]) sum[i]=sum[j],意思就是如果dp转移后,如果最长长度相同,那么证明有多种转移方式,那么sum就要把多种的都加起来,如果这是新转移的,那么直接等于sum[j]。这个时候如果数据是321321就会有很多种重复情况,这时就要去重,有两个地方要去重,第一个是在计算dp的值的时候,对于同一个个数转移过来的要去重,如32xxxx和3xxx2x这两种,这时如果在3xxx2x 中间的xxx都没有比2大的数那么肯定是取前面的2,后面的2就可以去掉了。第二个是在计算sum的时候,一旦遇到相同的数,就要跳出循环,否则会重复计算,详见代码理解。


#include<iostream>
using namespace std;
const int MAXN=5005;

int a[MAXN];  
int ans1,ans2;  
int sum[MAXN],dp[MAXN];  
int mark[MAXN];

int main()  
{  
    int n;  
    while(~scanf("%d",&n))  { 
        
        for(int i=0;i<n;i++){  
            scanf("%d",&a[i]);  
            mark[i]=1;
            dp[i]=1;  
            sum[i]=1;
        } 
        
        ans1=ans2=0;  
        for(int i=0;i<n;i++){  
            for(int j=i-1;j>=0;j--){  
                if(a[i]<a[j]&&mark[j]==1){  
                    if(dp[i]==dp[j]+1)  
                        sum[i]+=sum[j];  
                    else{
                        if(dp[i]<dp[j]+1){  
                            dp[i]=dp[j]+1;  
                            sum[i]=sum[j];  
                        } 
                    }
                }  
                else{ 
                    if(a[i]==a[j]){  
                        if(dp[i]==1)//如果两个数相等,并且这两个数之间没有比a[i]还要大的数,那么肯定是a[j]的贡献大,把a[i]去掉。否则后面会重复计算最长下降子序列。  
                            mark[i]=0;  
                        break;//再往前算就会重复了,因此退出此循环。  
                    }  
                }
            }  
            if(ans1<dp[i])  
                ans1=dp[i];  
        }  
        for(int i=0;i<n;i++)  
            if(ans1==dp[i])  
                ans2+=sum[i];  
        
        printf("%d %d\n",ans1,ans2);  
    }  
    return 0;  
}  








  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值