ZOJ - 4034 Mahjong Sorting (2018浙江省赛 K)

Mahjong Sorting

Time Limit: 1 Second       Memory Limit: 65536 KB

DreamGrid has just found a set of Mahjong with  suited tiles and a White Dragon tile in his pocket. Each suited tile has a suit (Character, Bamboo or Dot) and a rank (ranging from 1 to ), and there is exactly one tile of each rank and suit combination.

Character tiles whose rank ranges from 1 to 9

Bamboo tiles whose rank ranges from 1 to 9

Dot tiles whose rank ranges from 1 to 9

White Dragon tile

As DreamGrid is bored, he decides to play with these tiles. He first selects one of the  suited tiles as the "lucky tile", then he picks  tiles from the set of  tiles and sorts these  tiles with the following rules:

  • The "lucky tile", if contained in the  tiles, must be placed in the leftmost position.

  • For two tiles  and  such that neither of them is the "lucky tile", if

    •  is a Character tile and  is a Bamboo tile, or

    •  is a Character tile and  is a Dot tile, or

    •  is a Bamboo tile and  is a Dot tile, or

    •  and  have the same suit and the rank of  is smaller than the rank of ,

    then  must be placed to the left of .

White Dragon tile is a special tile. If it's contained in the  tiles, it's considered as the original (not-lucky) version of the lucky tile during the sorting. For example, consider the following sorted tiles, where "3 Character" is selected as the lucky tile. White Dragon tile, in this case, is considered to be the original not-lucky version of "3 Character" and should be placed between "2 Character" and "4 Character".

As DreamGrid is quite forgetful, he immediately forgets what the lucky tile is after the sorting! Given  sorted tiles, please tell DreamGrid the number of possible lucky tiles.

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains two integers  and  (), indicating the number of sorted tiles and the maximum rank of suited tiles.

For the next  lines, the -th line describes the -th sorted tile counting from left to right. The line begins with a capital letter  (), indicating the suit of the -th tile:

  • If , then an integer  () follows, indicating that it's a Character tile with rank ;

  • If , then an integer  () follows, indicating that it's a Bamboo tile with rank ;

  • If , then an integer  () follows, indicating that it's a Dot tile with rank ;

  • If , then it's a White Drangon tile.

It's guaranteed that there exists at least one possible lucky tile, and the sum of  in all test cases doesn't exceed .

Output

For each test case output one line containing one integer, indicating the number of possible lucky tiles.

Sample Input
4
3 9
C 2
W
C 4
6 9
C 2
C 7
W
B 3
B 4
D 2
3 100
C 2
W
C 9
3 9
C 1
B 2
D 3
Sample Output
2
4
7
25
Hint

For the first sample, "2 Character" and "3 Character" are possible lucky tiles.

For the second sample, "8 Character", "9 Character", "1 Bamboo" and "2 Bamboo" are possible lucky tiles.


Author:  CHEN, Shihan
Source:  The 15th Zhejiang Provincial Collegiate Programming Contest Sponsored by TuSimple


题意:给你一堆麻将。然后随机抽N个出来,然后排序。规则按照题目要求。问你特殊牌的 可能性有多少种


解题思路:把所有情况都考虑就好了。主要包括如下几种情况


1 100

W


2 100

W

C 100


3 100

C 100

C 1

C 2


3 100

C 100

W

D 100


4 100

C 100

B 1

D 100


3 100

C 100

B 1

B 2


3 100

C 100

C 1

W


4 100 //WA的应该多数是这种没考虑。应该输出1

C 100

C 1

W

B 1


#include <bits/stdc++.h>
using namespace std;
typedef long long int ll;


int a[1000005];

int main()
{
    int T;
    scanf("%d",&T);
    int N,M;
    while(T--){
        scanf("%d%d",&N,&M);
        a[N]=3*M+1;
        char c;
        int k;
        int index=-1;
        for(int i=0;i<N;i++){
            cin>>c;
            if(c=='C'){
                cin>>k;
                a[i]=k;
            }
            if(c=='B'){
                cin>>k;
                a[i]=M+k;
            }
            if(c=='D')
            {
                cin>>k;
                a[i]=M+M+k;
            }
            if(c=='W'){
                index=i;
            }
        }

        if(N==1){
            cout<<3*M<<endl;
        }
        else{

            if(index==-1){
                if(a[0]>a[1])
                    cout<<1<<endl;
                else
                    cout<<3*M-N+1<<endl;
            }
            else{
                if(index==0){
                    cout<<a[1]-1<<endl;
                }
                else{
                    if(a[0]>a[1]&&index!=1)
                        cout<<1<<endl;
                    else{
                        int sum=a[index+1]-a[index-1]-1;
                        if(index==1)
                            sum++;
                        cout<<sum<<endl;
                    }
                }
            }
        }



    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值