PAT_甲级_1009

1009 Product of Polynomials (25 分)
This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​ ​​ N​2​​ a​N2​​ ​​ … N​K​​ a​NK
​​
where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​ ​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​ <⋯<N2​​ <N​1​​ ≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

搞清楚系数和指数的对应关系即可

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
double arr[2010];
double result[2010];
int num;
int count = 0;
int main()
{
    memset(arr, 0, sizeof(arr));
    memset(result, 0, sizeof(result));
    int ex_temp; 		//指数
    double co_temp;		//系数
    cin >> num;
    for (int i = 0; i < num; i++) {
        cin >> ex_temp >> co_temp;
        arr[ex_temp] = co_temp;
    }
    cin >> num;
    for (int i = 0; i < num; i++) {
        cin >> ex_temp >> co_temp;
        for (int j = 0; j < 1010; j++) {
            if (arr[j] != 0) {
                result[j + ex_temp] += co_temp * arr[j];
            }
        }
    }
    for (int i = 0; i < 2010; i++) {
        if (result[i] != 0) {
            count++;
        }
    }
    printf("%d", count);
    for (int i = 2010; i >= 0; i--) {
        if (result[i] != 0) {
            printf(" %d %.1f", i, result[i]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值