PAT_甲级_1100

1100 Mars Numbers

People on Mars count their numbers with base 13:

Zero on Earth is called “tret” on Mars.
The numbers 1 to 12 on Earth is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.
For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:
For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

注意点:
1、getline前要用一个getchar读取换行符
2、按照测试例子,13的倍数地位不输出0

#include<iostream>
#include<stdio.h>
#include<map>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;
string low_digit[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string high_digit[13] = {"tret", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
map<string, int> arr_h, arr_l;
int main()
{
    int n;
    cin >> n;
    string temp;
    for (int i = 0; i < 13; i++) {
        arr_h[high_digit[i]] = i;
        arr_l[low_digit[i]] = i;
    }
    getchar();
    for (int i = 0; i < n; i++) {
        getline(cin, temp);
        if (temp[0] <= '9' && temp[0] >= '0') {
            int num_temp = atoi(temp.c_str());
            int high_d = num_temp / 13;
            int low_d = num_temp % 13;
            if (high_d != 0 && low_d == 0) {
                cout << high_digit[high_d] << endl;
            } else if (high_d != 0 && low_d != 0) {
                cout << high_digit[high_d] << ' ' << low_digit[low_d] << endl;
            } else {
                cout << low_digit[low_d] << endl;
            }
        } else {
            if (temp.size() > 4) {
                string a = temp.substr(0, 3);
                string b = temp.substr(4, 3);
                cout << arr_h[a] * 13 + arr_l[b] << endl;
            } else if (temp.size() == 3 && arr_l.find(temp) == arr_l.end()){
                cout << arr_h[temp] * 13 << endl;
            } else {
                cout << arr_l[temp] << endl;
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值