PAT_甲级_1021

1021 Deepest Root

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​ ) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:
For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

注意点:
1、理解计算步骤。
2、最后的并集,有可能有重复的元素,注意排除。
3、

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<vector>
#include<string.h>
using namespace std;
vector<int> G[10010];
int visited[10010] = {0};
vector<int> ans;
vector<int> max_node;
int n;
int max_level = 1;
bool cmp(int a, int b)
{
    return a < b;
}
void DFS(int index, int height)
{
    visited[index] = 1;
    if (height == max_level) {
        max_node.push_back(index);
    } else if (height > max_level) {
        max_level = height;
        max_node.clear();
        max_node.push_back(index);
    }
    for (int i = 0; i < G[index].size(); i++) {
        int temp = G[index][i];
        if (visited[temp] == 0) {
            DFS(temp, height + 1);
        }
    }
}
int main()
{
    scanf("%d", &n);
    for (int i = 0; i < n - 1; i++) {
        int temp_1, temp_2;
        scanf("%d%d", &temp_1, &temp_2);
        G[temp_1].push_back(temp_2);
        G[temp_2].push_back(temp_1);
    }
    int _count = 0;
    for (int i = 1; i <= n; i++) {
        if (visited[i] == 0) {
            DFS(i, 1);
            _count++;
        }
    }
    if (_count != 1) {
        printf("Error: %d components\n", _count);
        return 0;
    }
    max_level = 1;
    max_node.clear();
    memset(visited, 0, sizeof(visited));
    DFS(1, 1);
    ans = max_node;
    max_node.clear();
    max_level = 1;
    memset(visited, 0, sizeof(visited));
    DFS(ans[0], 1);
    for (int i = 0; i < max_node.size(); i++) {
        ans.push_back(max_node[i]);
    }
    sort(ans.begin(), ans.end(), cmp);
    printf("%d\n", ans[0]);
    for (int i = 1; i < ans.size(); i++) {
        if (ans[i] != ans[i - 1]) {
            printf("%d\n", ans[i]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值