统计一个整数中数字的个数

描述
输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:
读入 1 个整数n(n<10^100),统计并输出n中2 的个数。
输入
见sample
输出
见sample
输入样例 1
3
-21902
2
345543
输出样例 1
count=2
count=1
count=0

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int repeat,k=0;
    string n;//n的范围很大,不可以使用long long
    scanf("%d",&repeat);
    getchar();
    while(repeat--)
    {
        while(getline(cin,n))
        {
            for(int i=0; n[i]!='\0'; i++)
            {
               if(n[i]=='2')
               {
                   k++;
               }
            }
            printf("count=%d\n",k);
            k=0;
        }
    }
    return 0;
}

这种方法仅仅只适用余与n较小时,不适用于此题

#include <stdio.h>
#include <stdlib.h>

int CountDight(int n)
{
    int count=0,i;
    if(n<0)
    {
        n=-n;
    }
    while(n>10)
    {
        i=n%10;
        if(i==2)
        {
            count++;
        }
        n=n/10;
    }
    if(n==2)
    {
        count++;
    }
    return count;
}
int main()
{
    int repeat,n;
    scanf("%d",&repeat);
    while(repeat--)
    {
        scanf("%d",&n);
        printf("count=%d\n",CountDight(n));
    }
    return 0;
}

  • 2
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值