2^x mod n = 1

描述
Give a number n, find the minimum x that satisfies 2^x mod n = 1.
输入
One positive integer on each line, the value of n.
输出
If the minimum x exists, print a line with 2^x mod n = 1.
Print 2^? mod n = 1 otherwise.
You should replace x and n with specific numbers.

输入样例 1
2
5
输出样例 1
2^? mod 2 = 1
2^4 mod 5 = 1

使用了数论的乘法逆元思想
根据模P乘法逆元:对于整数a、p如果存在整数b,满足a*b mod p=1则称b是a的模P乘法逆元。
a存在模P的乘法逆元的充要条件是gcd(a,p)=1,令a=2^x,b=1,p=n
则若存在x使用2^x mod n=1则gcd(2^x,n)=1
(1)因为要求x的值大于0。则2^x 的因子中只有一个2,所以当n为偶数时gcd(2^x,n) =2k(k=1,2,3…),即此时不存在x使得2^x mod n=1。
(2)当n为奇数时gcd(2^x ,n)=1,则必存在x使得2^x mod n=1。
(3)由于任何数模1的结果为0,所以当n=1时,无论x取何值,2^x mod n=0.
综合上述(1),(2),(3),当n的值为1或偶数时,不存在x使得2^x mod n=1,其它情况则必存在一x使得2^x mod n =1。

#include <stdio.h>

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n%2==0||n==1)
            printf("2^? mod %d = 1\n",n);
        else
        {
            int x=1,t=2;
            while(t%n!=1)
            {
                t=(t*2)%n;
                x++;
            }
            printf("2^%d mod %d = 1\n",x,n);
        }
    }
    return 0;
}


还有其他方法参考
https://blog.csdn.net/foreverlove111/article/details/70504631

#include <stdio.h>
#include <stdlib.h>

int main(
{
    int mod,n,x,y;
    while(scanf("%d",&n)!=EOF)
    {
        if(n<=1||n%2==0)
        {
            printf("2^? mod %d = 1\n",n);
            continue;
        }
        for(x=1,mod=2;; x++,mod+=mod)
        {
            if(mod>n)   mod-=n;
            if(mod==1) break;
        }
        printf("2^%d mod %d = 1\n",x,n);
    }
    return 0;
}

#include <stdio.h>
#include <math.h>

int main()
{

    int n,i;
    while(~scanf("%d",&n))
    {
        for(i=1; i<20; i++)
        {
            if(((int)pow(2,i) % n) == 1)
                break;
        }

        if(i <20)
            printf("2^%d mod %d = 1\n",i, n);
        else
            printf("2^? mod %d = 1\n",n);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值