字符串替换

将文本文件中指定的字符串替换成新字符串。 由于目前的OJ系统暂时不能支持用户读入文件,我们编写程序从键盘输入文件中的内容,当输入的一行为end时,表示结束。end后面有两个字符串,要求用第二个字符串替换文本中所有的第一个字符串。


输入样例:

Xi’an Institute of Posts and Telecommunications is co-designed and implemented by
by the People’s Government of Shaanxi Province and the Ministry of Industry and
Information Technology. The Institute is located in Xi’an,a historic city in
Northwest China, famous for its magnificent ancient culture.
end
Institute
University

输出样例:

Xi’an University of Posts and Telecommunications is co-designed and implemented by
by the People’s Government of Shaanxi Province and the Ministry of Industry and
Information Technology. The University is located in Xi’an,a historic city in
Northwest China, famous for its magnificent ancient culture.

import java.util.Scanner;
public class StringReplace{
	public static void main(String[] args){
		Scanner in=new Scanner(System.in);
		String string="";
		while(in.hasNextLine()){
			String s=in.nextLine();
			if(s.equals("end")){
				break;
			}
			else{
				string=string+s+"\n";
			}
		}
		String a=in.next();
		String b=in.next();
		System.out.println(string.replaceAll(a, b));
	}
}


  • 2
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值