HDU4722~Good Numbers(思路)

Good Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4728    Accepted Submission(s): 1502


Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
 

Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

Sample Input
  
  
2 1 10 1 20
 

Sample Output
  
  
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:   6018  6017  6016  6015  6014 
一个数字,每位加起来的和可以整除10,则这个数是个好数。。。可以看出,每隔10,必然有一个好数
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<stdlib.h>
#include<queue>
#include<vector>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define LL long long int
using namespace std;
LL solve(LL x)
{
    //x/10*10之前有多少个好数
    LL sum=x/10;
    //不知道怎么描述这个数了,自己理解把。。
    LL first=x/10*10;
    for(LL i=first;i<=x;i++)
    {
        LL m=i,temp=0;
        while(m)
        {
            temp+=(m%10);
            m/=10;
        }
        if((temp%10)==0)
            return sum+1;
    }
    return sum;
}
int main()
{
    LL t,q=0;
    scanf("%lld",&t);
    while(t--)
    {
        LL a,b;
        scanf("%lld%lld",&a,&b);
        a--;
        LL sum1=solve(a);
        if(a<0)sum1=0;
        LL sum2=solve(b);
        printf("Case #%lld: ",++q);
        printf("%lld\n",abs(sum2-sum1));

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值