HDU1059-Dividing(多重背包+二进制优化)

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25851    Accepted Submission(s): 7400


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.

多重背包,但直接写会超时,此时就用到了背包的二进制优化;

几个月之后,再写这题就不知要简单地会写就行了,百度了一下多重背包背包二进制优化的原理,大致如下:

为何是选择二进制,不是三进制四进制?

因为二进制可以组合成其中的任意一种数,就拿7来说,7的二进制是111,可以分为1,10,100,他们可以组合成小于等于7的任意一个数,所以直接转换成二进制跑01背包,这样就考虑到了每一种组合的情况,也就考虑到了装入物品的每一种情况

#include <iostream>
#include<cstdio>
#include<cstring>
#define mem(a,b) memset(a,b,sizeof(a))
#define N 60010
#define ll long long
using namespace std;
int d[N],v,a[10];
void bag01(int c,int w)
{
    for(int i=v;i>=c;i--)
        d[i]=max(d[i],d[i-c]+w);
}
void complete_bag(int c,int w)
{
    for(int i=c;i<=v;i++)
        d[i]=max(d[i],d[i-c]+w);
}
void multi_bag(int c,int w,int n)
{
    if(c*n>=v)
    {
        complete_bag(c,w);
        return;
    }
    int k=1;
    while(k<=n)
    {
        bag01(k*c,k*w);
        n=n-k;
        k<<=1;
    }
    bag01(n*c,n*w);
}
int main()
{
    int n,q=1;
    while(~scanf("%d",&a[1]))
    {
        int sum=a[1];
        for(int i=2;i<=6;i++)
        {
            scanf("%d",&a[i]);
            sum+=i*a[i];
        }
        if(!sum)return 0;
        printf("Collection #%d:\n",q++);
        if(sum%2==1)
        {
            printf("Can't be divided.\n\n");
            continue;
        }
        else
        {
            v=sum/2;
            mem(d,0);
            for(int i=1;i<=6;i++)
            {
                if(a[i])
                multi_bag(i,i,a[i]);
            }
           if(v==d[v]) printf("Can be divided.\n\n");
        else printf("Can't be divided.\n\n");
        }
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值