POJ2585~Window Pains(拓扑排序)

Window Pains
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2168 Accepted: 1102

Description

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux's windows would be represented by the following 2 x 2 windows: 
11..
11..
....
....
.22.
.22.
....
....
..33
..33
....
....
....
44..
44..
....
....
.55.
.55.
....
....
..66
..66
....
....
....
77..
77..
....
....
.88.
.88.
....
....
..99
..99
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window  1 and then window  2 were brought to the foreground, the resulting representation would be:
122?
122?
????
????
If window 4 were then brought to the foreground:
122?
442?
44??
????
. . . and so on . . . 
Unfortunately, Boudreaux's computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 3 components: 
  1. Start line - A single line: 
    START 

  2. Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux's screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space. 
  3. End line - A single line: 
    END 

After the last data set, there will be a single line: 
ENDOFINPUT 

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.

Output

For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux's screen, the output will be a single line with the statement: 

THESE WINDOWS ARE CLEAN 

Otherwise, the output will be a single line with the statement: 
THESE WINDOWS ARE BROKEN 

Sample Input

START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output

THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN

首先要统计覆盖(i,j)位置的窗口的集合,由于1~9每一个数字都限制了位置,所以直接模拟一遍得出覆盖窗口的集合;

最关键的在于建立每一个数字之间的对应关系——建边,如何才能建边?

(i,j)这一位置对应的数字k与(i,j)这一点覆盖窗口的集合中每一个元素(除自己本身)都可以建边,因为这个集合中其他任意的元素都可能覆盖这一位置

最后拓扑排序即可。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<string>
#include<queue>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
int screen[10][10],id[10],t;
bool e[10][10],vis[10];
char s[10];
string book[5][5];
void init()
{
    int k=1;
    for(int i=0; i<3; i++)
        for(int j=0; j<3; j++)
        {
            book[i][j]+=char('0'+k);
            book[i+1][j]+=char('0'+k);
            book[i][j+1]+=char('0'+k);
            book[i+1][j+1]+=char('0'+k);
            k++;
        }
}
bool solve()
{
    for(int i=0; i<4; i++)
    {
        for(int j=0; j<4; j++)
        {
            for(int k=0; k<book[i][j].length(); k++)
            {
                if((!e[screen[i][j]][book[i][j][k]-'0'])&&(screen[i][j]!=book[i][j][k]-'0'))//每个位置当前点和这个位置所有可能的数字建边
                {
                    e[screen[i][j]][book[i][j][k]-'0']=1;
                    id[book[i][j][k]-'0']++;
                }
            }
        }
    }
    while(t--)//因为有t个点,所以只需要找到t个入度为0的点,相当于每次把这个数字去掉
    {
        int u=-1;
        for(int i=1; i<=9; i++)
        {
            if(vis[i]&&!id[i])
            {
                vis[i]=false;
                u=i;
                break;
            }
        }
        if(u==-1)return false;
        for(int j=1; j<=9; j++)
        {
            if(vis[j]&&e[u][j]>0)//建边是为了判断每个点是否出现在了应有的区域以外
            {
                id[j]--;
            }
        }
    }
    return true;
}
int main()
{
    init();
    while(~scanf("%s",s))
    {
        if(s[0]=='S')
        {
            t=0;
            mem(vis,false);
            mem(e,false);
            mem(id,0);
            for(int i=0; i<4; i++)
                for(int j=0; j<4; j++)
                {
                    scanf("%d",&screen[i][j]);
                    if(!vis[screen[i][j]])t++;
                    vis[screen[i][j]]=1;
                }
            if(solve())
                printf("THESE WINDOWS ARE CLEAN\n");
            else
                printf("THESE WINDOWS ARE BROKEN\n");

        }
        else
        {
            if(!strcmp(s,"ENDOFINPUT"))
                break;
            else
                continue;
        }
    }
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值