HDU 1513 Palindrome(dp最大公共子序列+滚动数组)

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6013    Accepted Submission(s): 2002


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
  
  
5 Ab3bd
 

Sample Output
  
  
2

这题有点类似于最大子序列,既然要求填补多少个字母能组成回文串,根据回文串的特点,将原本的字符串倒着存,然后求两串的最大公共子序列,用总长度,减去最大公共子序列,即是答案;

思路有了,但是发现数据范围5000,一般求最大公共子序列是用n*n的二维数组刷新,这里空间肯定不够,此时就要引入一个新概念:滚动数组

滚动数组概念可参考博客:飘过的小牛

我们发现,每次刷新最大值,只用到了上一层的状态,而其他的状态都浪费了,因此,用滚动数组,每次把上上一次的状态覆盖就行了;

#include <iostream>
#include<stdio.h>
#include<cctype>
#include<string.h>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int N=5005;
char s1[N],s2[N];
int dp[2][N];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        scanf("%s",s1+1);
        for(int i=1;i<=n;i++)
        {
            s2[i]=s1[n-i+1];
        }
        mem(dp,0);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(s1[i]==s2[j])
                {
                    dp[i%2][j]=max(dp[i%2][j],dp[(i-1)%2][j-1]+1);
                }
                else
                {
                    dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
                }
            }
        }
        printf("%d\n",n-dp[n%2][n]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值