POJ2528 Mayor's posters (线段树+离散化)

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 66380 Accepted: 19164

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

又是一道区间覆盖问题,由于给出数据非常大,要离散化;

但是这里离散化会有这样一种情况 

1-10 1-4 5-10

1-10 1-4 6-10

会发现这两种情况,离散化都是 1 2 3 4,但他们的答案却不同,前为2,后为3

为什么会出现这种情况,因为如果两个区间前者的右+1=后者左时才会完全覆盖,而离散化会把他们都考虑成完全覆盖

为避免这种情况  可以判断一下,如果后面>前面+1,那么在离散化中添一个前面+1,这样就把区间隔开了

表达不清楚,具体看代码吧

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<map>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
typedef long long ll;
const int inf=0x3f3f3f3f;
const int N=20005;
struct node
{
    int x,y;
}e[N];
int pos[N<<1],t[N<<3],ans;
bool book[N<<3];
void pushdown(int rt)
{
    if(t[rt]!=-1)
    {
        t[rt<<1]=t[rt<<1|1]=t[rt];
        t[rt]=-1;
    }
}
void update(int x,int y,int l,int r,int rt,int val)
{
    if(l>=x&&r<=y)
    {
        t[rt]=val;
        return;
    }
    pushdown(rt);
    int m=(l+r)>>1;
    if(x<=m)update(x,y,l,m,rt<<1,val);
    if(y>m)update(x,y,m+1,r,rt<<1|1,val);
}
void query(int l,int r,int rt)
{
    if(t[rt]!=-1)
    {
        if(!book[t[rt]])
        {
            ans++;
            book[t[rt]]=true;
        }
        return;
    }
    if(l==r)return;
    int m=(l+r)>>1;
    query(l,m,rt<<1);
    query(m+1,r,rt<<1|1);
}
int main()
{
    int tt,n;
    scanf("%d",&tt);
    while(tt--)
    {
        mem(book,false);
        mem(t,-1);
        mem(pos,0);
        int tot=1;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&e[i].x,&e[i].y);
            pos[++tot]=e[i].x;
            pos[++tot]=e[i].y;
        }
        sort(pos+1,pos+tot+1);
        int len=unique(pos+1,pos+tot+1)-pos;
        int cnt=len;
        for(int i=2;i<=cnt;i++)
        {
            if(pos[i]-pos[i-1]>1)
            {
                pos[++len]=pos[i-1]+1;
            }
        }
        sort(pos+1,pos+len+1);
        for(int i=0;i<n;i++)
        {
            int x=lower_bound(pos+1,pos+len+1,e[i].x)-pos;
            int y=lower_bound(pos+1,pos+len+1,e[i].y)-pos;
            update(x,y,1,len,1,i);
        }
        ans=0;
        query(1,len,1);
        printf("%d\n",ans);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值